aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1997-02-16 23:54:14 +0000
committerEric S. Raymond <esr@thyrsus.com>1997-02-16 23:54:14 +0000
commit2a7c2c8a122110bb09ce2019bca7a9a78d7846ff (patch)
tree439e9141f50868c8384d065ddf51becd84c2e0cd /Makefile.in
parent2a3e3be9b34b7554f976d45915316a134b465735 (diff)
downloadfetchmail-2a7c2c8a122110bb09ce2019bca7a9a78d7846ff.tar.gz
fetchmail-2a7c2c8a122110bb09ce2019bca7a9a78d7846ff.tar.bz2
fetchmail-2a7c2c8a122110bb09ce2019bca7a9a78d7846ff.zip
One-step RPM generation.
svn path=/trunk/; revision=889
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in19
1 files changed, 10 insertions, 9 deletions
diff --git a/Makefile.in b/Makefile.in
index 10351ea4..5f91b2af 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -94,7 +94,7 @@ srcs = $(srcdir)/socket.c $(srcdir)/getpass.c $(srcdir)/pop2.c \
.SUFFIXES:
.SUFFIXES: .o .c .h .y .l .ps .dvi .info .texi
-all: fetchmail fetchmail.spec
+all: fetchmail
# Some makes apparently use .PHONY as the default goal if it is before `all'.
.PHONY: all check
@@ -104,6 +104,9 @@ $(protobjs): fetchmail.h
fetchmail: $(srcdir)/rcfile_l.c $(srcdir)/rcfile_y.c $(objs)
$(CC) $(LDFLAGS) $(objs) $(LOADLIBS) -o fetchmail
+# Tester for address parsing
+rfc822: rfc822.c
+ gcc -DTESTMAIN -g rfc822.c -o rfc822
# -I. is needed to find config.h in the build directory.
.c.o:
@@ -148,9 +151,6 @@ $(bindir)/$(instname): fetchmail
$(mandir)/$(instname).$(manext): fetchmail.man
$(INSTALL_DATA) $(srcdir)/fetchmail.man $@
-fetchmail.spec: $(srcdir)/Makefile.in $(srcdir)/specgen.sh
- $(srcdir)/specgen.sh $(VERS) $(PL) >fetchmail.spec
-
.PHONY: clean realclean distclean mostlyclean
clean:
-rm -f fetchmail *.o core fetchmail.dvi \
@@ -162,7 +162,7 @@ distclean: clean
-rm -f Makefile config.h
-rm -f config.cache config.status config.log stamp-config
-rm -f TAGS tags
- -rm -f fetchmail.log fetchmail.toc fetchmail.*aux fetchmail.spec
+ -rm -f fetchmail.log fetchmail.toc fetchmail.*aux
realclean: distclean # fetchmail.info*
@@ -188,7 +188,6 @@ config.h.in: acconfig.h
# This tells versions [3.59,3.63) of GNU make not to export all variables.
.NOEXPORT:
-
# Special dependencies, not easily handled without explicit rules
$(srcdir)/rcfile_l.c: $(srcdir)/rcfile_l.l
$(srcdir)/rcfile_y.c: $(srcdir)/rcfile_y.y
@@ -221,9 +220,11 @@ fetchmail-$(VERS).tar: $(all)
fetchmail-$(VERS).tar.gz: fetchmail-$(VERS).tar
gzip -f fetchmail-$(VERS).tar
-# Tester for address parsing
-rfc822: rfc822.c
- gcc -DTESTMAIN -g rfc822.c -o rfc822
+RPMROOT=/usr/src/redhat
+rpm: fetchmail-$(VERS).tar.gz
+ cp fetchmail-$(VERS).tar.gz $(RPMROOT)/SOURCES;
+ $(srcdir)/specgen.sh $(VERS) $(PL) >$(RPMROOT)/SPECS/fetchmail.spec
+ cd $(RPMROOT)/SPECS; rpm -ba fetchmail.spec
# The automatically generated dependencies below may omit config.h
# because it is included with ``#include <config.h>'' rather than