aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-01-05 18:33:40 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-01-05 18:33:40 +0000
commit13d952ccc75721d9396dfea9484eaf203c764c4f (patch)
treee4d2f82531ad35b7eb99bb2e714e0d65261139ea /Makefile.in
parent12d0ef921c8276833cafc30c31462e265233390e (diff)
downloadfetchmail-13d952ccc75721d9396dfea9484eaf203c764c4f.tar.gz
fetchmail-13d952ccc75721d9396dfea9484eaf203c764c4f.tar.bz2
fetchmail-13d952ccc75721d9396dfea9484eaf203c764c4f.zip
Make --with-gettext work.
svn path=/trunk/; revision=3006
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in25
1 files changed, 19 insertions, 6 deletions
diff --git a/Makefile.in b/Makefile.in
index 9f732300..aaddb734 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -6,7 +6,7 @@
PACKAGE = fetchmail
VERSION = 5.6.2
-SUBDIRS = @INTLSUB@ @POSUB@
+SUBDIRS = @POSUB@
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
@@ -15,7 +15,7 @@ VPATH = @srcdir@
CC = @CC@
# CC = cc # QNX
-CFLAGS = @CFLAGS@
+CFLAGS = @CFLAGS@ -I$(top_srcdir)/intl
# CFLAGS = -g2 -5 # QNX
LDFLAGS = @LDFLAGS@
# LDFLAGS = -g2 -5 -N64k # QNX
@@ -29,6 +29,10 @@ CEFLAGS = @CEFLAGS@
CPFLAGS = @CPFLAGS@
LDEFLAGS = @LDEFLAGS@
+INTLDEPS = @INTLDEPS@
+INTLLIBS = @INTLLIBS@
+INTLOBJS = @INTLOBJS@
+
# How to invoke ranlib. This is only used by the `glob' subdirectory.
RANLIB = @RANLIB@
@@ -40,11 +44,11 @@ defines = $(DEFS)
# If your system needs extra libraries loaded in, define them here.
# In particular, add -lresolv if you are running bind 4.9.5
-LOADLIBS = @LIBS@ @LEXLIB@ @INTLLIBS@
+LOADLIBS = @LIBS@ @LEXLIB@
# LOADLIBS = -lsocket3r -lunix3r # QNX
# Any extra object files your system needs.
-extras = @LIBOBJS@
+extras = @LIBOBJS@ $(INTLDEPS)
# Extra sources/objects for library functions not provided on the host system.
EXTRASRC = @EXTRASRC@
@@ -63,11 +67,17 @@ exec_prefix = @exec_prefix@
bindir = @bindir@
# Directory to install the Info files in.
infodir = @infodir@
+# Directory to install data files.
+datadir = @datadir@
# Number to put on the man page filename.
manext = 1
# Directory to install the man page in.
mandir = @mandir@/man$(manext)
+# Toplevel build directory
+top_builddir = .
+top_srcdir = @top_srcdir@
+
# Program to install `make'.
INSTALL_PROGRAM = @INSTALL_PROGRAM@
# Program to install the man page.
@@ -115,10 +125,13 @@ all: fetchmail po
fetchmail: $(objs)
$(CC) $(LDEFLAGS) $(LDFLAGS) $(objs) $(LOADLIBS) -o fetchmail
-
po: dummy
@POMAKE@
+$(INTLDEPS): dummy
+ @echo "Making $@ in intl"; \
+ cd intl; $(MAKE) || exit 1
+
dummy:
# Tester for address parsing
@@ -139,7 +152,7 @@ netrc: netrc.c xmalloc.o error.o
# For some losing Unix makes.
SHELL = /bin/sh
-MAKE = make
+@SET_MAKE@
tagsrcs = $(srcs) rcfile_l.c rcfile_y.c
TAGS: $(tagsrcs)