aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1999-10-27 00:15:14 +0000
committerEric S. Raymond <esr@thyrsus.com>1999-10-27 00:15:14 +0000
commit0d1e69ae10af5eba7cd3426e802d40d17b6db218 (patch)
treed838573a667ed2ba75e04797f87eb9f45f1df05f /Makefile.in
parent8d293a3b12a5e2c4ecc6f70bcd59b862294458c8 (diff)
downloadfetchmail-0d1e69ae10af5eba7cd3426e802d40d17b6db218.tar.gz
fetchmail-0d1e69ae10af5eba7cd3426e802d40d17b6db218.tar.bz2
fetchmail-0d1e69ae10af5eba7cd3426e802d40d17b6db218.zip
This preliminary SSL patch goes to Mike.
svn path=/trunk/; revision=2643
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in35
1 files changed, 21 insertions, 14 deletions
diff --git a/Makefile.in b/Makefile.in
index 6033ae03..e1753c23 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -185,20 +185,27 @@ realclean: distclean
mostlyclean: clean
-config.status: configure Makefile.in
- $(srcdir)/configure
-
-config.h: config.status config.h.in
- sh config.status; touch config.h
-
-Makefile: config.status
- sh config.status
-
-configure: configure.in
- autoconf $(ACFLAGS)
-
-config.h.in: acconfig.h configure.in
- autoheader $(ACFLAGS); touch config.h.in
+# These magic rules are copied from the autoconf documentation
+
+${srcdir}/configure: configure.in aclocal.m4
+ cd ${srcdir} && autoconf
+
+# autoheader might not change config.h.in, so touch a stamp file.
+${srcdir}/config.h.in: stamp-h.in
+
+${srcdir}/stamp-h.in: configure.in aclocal.m4 acconfig.h # config.h.top config.h.bot
+ cd ${srcdir} && autoheader
+ echo timestamp> ${srcdir}/stamp-h.in
+
+config.h: stamp-h
+stamp-h: config.h.in config.status
+ ./config.status
+
+Makefile: Makefile.in config.status
+ ./config.status
+
+config.status: configure
+ ./config.status --recheck
# This tells versions [3.59,3.63) of GNU make not to export all variables.
.NOEXPORT: