aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2005-11-27 15:23:27 +0000
committerMatthias Andree <matthias.andree@gmx.de>2005-11-27 15:23:27 +0000
commitf750540a7bb3dd465cb562681a2606bd313469ad (patch)
tree6134b14fec0605fac81052cd5648f8275b9963a7 /Makefile.am
parentac97ca8cae0b55f18bd3cd6a33363ea97136b1c9 (diff)
downloadfetchmail-f750540a7bb3dd465cb562681a2606bd313469ad.tar.gz
fetchmail-f750540a7bb3dd465cb562681a2606bd313469ad.tar.bz2
fetchmail-f750540a7bb3dd465cb562681a2606bd313469ad.zip
Add rudimentary autobuild support.
Add a trivial self test, required for autobuild. svn path=/trunk/; revision=4479
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 21435d4a..474ecc44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,6 +46,9 @@ DEPENDENCIES= libfm.a $(LIBOBJS)
check_PROGRAMS=
+TESTS= t.smoke
+TESTS_ENVIRONMENT= srcdir="@srcdir@" LC_ALL=C TZ=UTC
+
if NEED_TRIO
noinst_LIBRARIES+= libtrio.a
libtrio_a_SOURCES= trio/triostr.c trio/trio.c trio/trionan.c \
@@ -54,7 +57,7 @@ libtrio_a_SOURCES= trio/triostr.c trio/trio.c trio/trionan.c \
check_PROGRAMS+= regression
regression_SOURCES= trio/regression.c
LDADD += libtrio.a -lm
-TESTS= regression
+TESTS+= regression
endif
fetchmail_SOURCES= fetchmail.h getopt.h \
@@ -106,7 +109,9 @@ EXTRA_DIST+= $(DISTDOCS) fetchmail.spec $(distdirs) ucs/README.svn \
trio/CHANGES trio/README \
strlcpy.3 \
m4-local/ac-archive-license.txt \
- m4-local/ac_ma_search_package.m4
+ m4-local/ac_ma_search_package.m4 \
+ m4-local/autobuild.m4 \
+ t.smoke t.rc
fetchmailconf:
( echo '#! /bin/sh' && echo 'exec @PYTHON@ @pythondir@/fetchmailconf.py "$$@"' ) >$@ || { rm -f $@ ; exit 1; }