aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2005-09-25 09:30:55 +0000
committerMatthias Andree <matthias.andree@gmx.de>2005-09-25 09:30:55 +0000
commite2d3d8d759cefa4080f60cc31fa2e52164692b3e (patch)
tree60b641af84938e493577f303724a1c019480cb49 /Makefile.am
parentcbba8e3be7176b18275635dbfb09ae1193ddfd90 (diff)
downloadfetchmail-e2d3d8d759cefa4080f60cc31fa2e52164692b3e.tar.gz
fetchmail-e2d3d8d759cefa4080f60cc31fa2e52164692b3e.tar.bz2
fetchmail-e2d3d8d759cefa4080f60cc31fa2e52164692b3e.zip
Move smb* sources to libfm_a_SOURCES, so that they only need to be linked if NTLM is needed.
svn path=/trunk/; revision=4320
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 7c5dad3a..8a828809 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,9 @@ localedir= $(datadir)/locale
DEFS= @DEFS@ -DLOCALEDIR=\"$(localedir)\"
noinst_LIBRARIES= libfm.a
-libfm_a_SOURCES= xmalloc.c base64.c rfc822.c report.c rfc2047e.c servport.c \
+libfm_a_SOURCES= xmalloc.c base64.c rfc822.c report.c rfc2047e.c \
+ servport.c ntlm.h smbbyteorder.h smbdes.h smbmd4.h \
+ smbencrypt.h smbdes.c smbencrypt.c smbmd4.c smbutil.c \
libesmtp/gethostbyname.h libesmtp/gethostbyname.c
libfm_a_LIBADD= $(EXTRAOBJ)
libfm_a_DEPENDENCIES= $(EXTRAOBJ)
@@ -44,16 +46,14 @@ TESTS= regression
endif
fetchmail_SOURCES= fetchmail.h getopt.h \
- i18n.h kerberos.h md5.h mx.h netrc.h ntlm.h \
- smbbyteorder.h smbdes.h smbmd4.h smbencrypt.h smtp.h \
+ i18n.h kerberos.h md5.h mx.h netrc.hsmtp.h \
socket.h tunable.h \
socket.c getpass.c pop2.c pop3.c imap.c etrn.c \
odmr.c fetchmail.c env.c idle.c options.c daemon.c \
driver.c transact.c sink.c smtp.c \
uid.c mxget.c md5ify.c cram.c kerberos.c gssapi.c \
opie.c rpa.c interface.c netrc.c \
- unmime.c conf.c checkalias.c smbdes.c smbencrypt.c \
- smbmd4.c smbutil.c lock.c \
+ unmime.c conf.c checkalias.c lock.c \
rcfile_l.l rcfile_y.y ucs/norm_charmap.c \
libesmtp/getaddrinfo.h libesmtp/getaddrinfo.c \
KAME/getnameinfo.c