aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2006-08-14 01:28:47 +0000
committerMatthias Andree <matthias.andree@gmx.de>2006-08-14 01:28:47 +0000
commitdf4a264f6a4bf53592f9e273462a8861ea7e6a6d (patch)
tree7fc180164f8bc204cea413b098a9068dbdc2c792 /Makefile.am
parentc625d7a00b024fe5de26d16b6420abebb1db705c (diff)
downloadfetchmail-df4a264f6a4bf53592f9e273462a8861ea7e6a6d.tar.gz
fetchmail-df4a264f6a4bf53592f9e273462a8861ea7e6a6d.tar.bz2
fetchmail-df4a264f6a4bf53592f9e273462a8861ea7e6a6d.zip
Wrap getaddrinfo() and block SIGALRM where needed.
Also wrap freeaddrinfo() without added functionality. svn path=/branches/BRANCH_6-3/; revision=4895
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c866488c..db06fee0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,7 +39,7 @@ libfm_a_SOURCES= xmalloc.c base64.c rfc822.c report.c rfc2047e.c \
servport.c ntlm.h smbbyteorder.h smbdes.h smbmd4.h \
smbencrypt.h smbdes.c smbencrypt.c smbmd4.c smbutil.c \
libesmtp/gethostbyname.h libesmtp/gethostbyname.c \
- smbtypes.h
+ smbtypes.h fm_getaddrinfo.c
libfm_a_LIBADD= $(EXTRAOBJ)
libfm_a_DEPENDENCIES= $(EXTRAOBJ)
LDADD = libfm.a @LIBINTL@ $(LIBOBJS)