aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2016-12-12 00:33:28 +0100
committerMatthias Andree <matthias.andree@gmx.de>2016-12-12 00:33:28 +0100
commitcb12429bbb357fc77f4eae50c9f2852e6cf830b4 (patch)
tree94762b05fe5401f9c8cb5fcd0de297e64e9fac0a /Makefile.am
parentb1e81d36e5a324d1e5257de396a3ff8ff99f71ca (diff)
downloadfetchmail-cb12429bbb357fc77f4eae50c9f2852e6cf830b4.tar.gz
fetchmail-cb12429bbb357fc77f4eae50c9f2852e6cf830b4.tar.bz2
fetchmail-cb12429bbb357fc77f4eae50c9f2852e6cf830b4.zip
Fail build early if socket.o cannot be generated.
This is a hack to fail quickly on old OpenSSL versions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c1a7aab..c7e97b8b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,10 @@ AUTOMAKE_OPTIONS= 1.11 foreign no-dist-gzip dist-bzip2 dist-xz subdir-objects
AM_CPPFLAGS= -I$(srcdir)/libesmtp
ACLOCAL_AMFLAGS= -I m4 -I m4-local
AM_YFLAGS= -d
-BUILT_SOURCES= rcfile_y.h
+# listing socket.$(OBJEXT) here is a hack to compile socket.c pretty
+# early in order to fail it early on outdated OpenSSL libraries,
+# without building a few dozen other files first.
+BUILT_SOURCES= rcfile_y.h socket.$(OBJEXT)
bin_PROGRAMS= fetchmail