aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2006-04-01 15:11:32 +0000
committerMatthias Andree <matthias.andree@gmx.de>2006-04-01 15:11:32 +0000
commitc324c5795176ace49f364980e4a9fa0ece31b030 (patch)
treec02bfc8970b51b40423304801459dca0c77d4254 /Makefile.am
parent781363cc71872ca5d22d696eddc8f9a26631c70a (diff)
downloadfetchmail-c324c5795176ace49f364980e4a9fa0ece31b030.tar.gz
fetchmail-c324c5795176ace49f364980e4a9fa0ece31b030.tar.bz2
fetchmail-c324c5795176ace49f364980e4a9fa0ece31b030.zip
Add rsync target to help with testing fetchmail compiles.
svn path=/branches/BRANCH_6-3/; revision=4768
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2a7b3401..a4476777 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -156,6 +156,13 @@ dist-hook:
lsm: genlsm.sh dist
$(SHELL) genlsm.sh >$(PACKAGE)-$(VERSION).lsm
+# this target expects a .rsyncs file with lines of this format:
+# host:directory/
+# it will call rsync from its source directory to the destination for
+# each of them, running them in parallel
+rsync: distdir $(srcdir)/.rsyncs
+ @( cat $(srcdir)/.rsyncs | sed -e 's}^}rsync -aH --delete-after $(PACKAGE)-$(VERSION)/ }; s/\($$\)/ \&/;' ; echo "wait" ) | $(SHELL) -x
+
# The following sets edit modes for GNU EMACS.
# Local Variables:
# compile-command:"configure"