aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2005-12-04 10:57:35 +0000
committerMatthias Andree <matthias.andree@gmx.de>2005-12-04 10:57:35 +0000
commit9b023cd530abe6ee2a9a7ba2a09f45d456aa2069 (patch)
tree57b2607be55217090080d3e2c5bceebc58bc1a8c /Makefile.am
parent09e87694984e70cca180c27252d5d79fa4fa2d80 (diff)
downloadfetchmail-9b023cd530abe6ee2a9a7ba2a09f45d456aa2069.tar.gz
fetchmail-9b023cd530abe6ee2a9a7ba2a09f45d456aa2069.tar.bz2
fetchmail-9b023cd530abe6ee2a9a7ba2a09f45d456aa2069.zip
Support 'make lsm' to generate a .lsm file for ftp.ibiblio.com:/pub/Linux uploads.
This is meant to replace the insufficient rpm2lsm script. svn path=/branches/BRANCH_6-3/; revision=4502
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 764ca606..2d234b77 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -147,6 +147,10 @@ dist-hook:
cd $(distdir) && find $(distdirs) po -name .svn -type d -prune -exec rm -rf '{}' ';'
cd $(distdir) && find $(distdirs) po -name '*~' -exec rm -f '{}' ';'
+.PHONY: lsm
+lsm: genlsm.sh dist
+ $(SHELL) genlsm.sh >$(PACKAGE)-$(VERSION).lsm
+
# The following sets edit modes for GNU EMACS.
# Local Variables:
# compile-command:"configure"