aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2020-08-27 18:27:03 +0200
committerMatthias Andree <matthias.andree@gmx.de>2020-08-27 19:04:44 +0200
commit7e89e880194e38c087099312c56631d84eddf4cb (patch)
treede3401e73a0a2a696fc18d4b873948b4e78c5876 /Makefile.am
parentcddf65c3f55a2a8ec000d4e8505ecb686726c7cc (diff)
downloadfetchmail-7e89e880194e38c087099312c56631d84eddf4cb.tar.gz
fetchmail-7e89e880194e38c087099312c56631d84eddf4cb.tar.bz2
fetchmail-7e89e880194e38c087099312c56631d84eddf4cb.zip
Makefile.am, dist-tools: check for new translations in dist-hook
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 2ba02438..083c5340 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -193,6 +193,7 @@ EXTRA_DIST= $(DISTDOCS) $(distdirs) \
$(TESTS) t.rc t.regression \
dist-tools/html2txt \
dist-tools/manServer.pl \
+ dist-tools/git-commit-po-updates.sh \
Doxyfile
fetchmailconf:
@@ -224,9 +225,12 @@ fetchmail-man.html: fetchmail.man $(srcdir)/dist-tools/manServer.pl
env - "PATH=$$PATH" perl -T $(srcdir)/dist-tools/manServer.pl $(srcdir)/fetchmail.man >$@ \
|| { rm -f $@ ; exit 1 ; }
-dist-hook:
+dist-hook: fetch-translations
cd $(distdir) && find $(distdirs) po -name .git -type d -prune -exec rm -rf '{}' ';'
cd $(distdir) && find $(distdirs) po -name '*~' -exec rm -f '{}' ';'
+ if ! $(top_srcdir)/dist-tools/git-commit-po-updates.sh -n ; then \
+ printf '\n*** There are new translations. Please add them to the distribution. ***\n\n' ; exit 1 ; \
+ fi
# this target expects a .rsyncs file with lines of this format:
# host:directory/
@@ -235,9 +239,11 @@ dist-hook:
rsync: distdir $(srcdir)/.rsyncs
@( cat $(srcdir)/.rsyncs | sed -e 's}^}rsync -aH --delete-after $(PACKAGE)-$(VERSION)/ }; s/\($$\)/ \&/;' ; echo "wait" ) | $(SHELL) -x
-.PHONY: import-translations git-check
-import-translations:
+.PHONY: import-translations fetch-translations git-check
+fetch-translations:
rsync -Lrtvz translationproject.org::tp/latest/fetchmail/ $(top_srcdir)/po
+
+import-translations: fetch-translations
cd $(top_builddir)/po && $(MAKE) update-po
@printf '\n=== You can use dist-tools/git-commit-po-updates.sh to check these updates in. ===\n\n'