aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2010-10-09 12:24:45 +0200
committerMatthias Andree <matthias.andree@gmx.de>2010-10-09 12:24:45 +0200
commit4995b4a7eebe3b9cd620b094cba5fbdc02c2f042 (patch)
tree63a123e7400cb43d82f1bc2a4ba1f3d0d6f5b8c3 /Makefile.am
parentc0db499f36439269c81c0d83fc4655502985bbc5 (diff)
downloadfetchmail-4995b4a7eebe3b9cd620b094cba5fbdc02c2f042.tar.gz
fetchmail-4995b4a7eebe3b9cd620b094cba5fbdc02c2f042.tar.bz2
fetchmail-4995b4a7eebe3b9cd620b094cba5fbdc02c2f042.zip
Avoid compiling empty C files if NTLM is disabled.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 973bf400..3947beaf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,7 +39,10 @@ libfm_a_SOURCES= xmalloc.c base64.c rfc822.c report.c rfc2047e.c \
libesmtp/gethostbyname.h libesmtp/gethostbyname.c \
smbtypes.h fm_getaddrinfo.c tls.c rfc822valid.c \
xmalloc.h sdump.h sdump.c x509_name_match.c \
- fm_strl.h ntlmsubr.c
+ fm_strl.h
+if NTLM_ENABLE
+libfm_a_SOURCES += ntlmsubr.c
+endif
libfm_a_LIBADD= $(EXTRAOBJ)
libfm_a_DEPENDENCIES= $(EXTRAOBJ)
LDADD = libfm.a @LIBINTL@ $(LIBOBJS)