aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2005-08-28 15:12:39 +0000
committerMatthias Andree <matthias.andree@gmx.de>2005-08-28 15:12:39 +0000
commit4680b0f8c728a69a24e7089b777f03899bab6c9f (patch)
tree15ca79e508d206308b3aaa65a747ddb1d54d32fc /Makefile.am
parent865694ffd4df6b32eb81722fa6b851fb73a45271 (diff)
downloadfetchmail-4680b0f8c728a69a24e7089b777f03899bab6c9f.tar.gz
fetchmail-4680b0f8c728a69a24e7089b777f03899bab6c9f.tar.bz2
fetchmail-4680b0f8c728a69a24e7089b777f03899bab6c9f.zip
Large protocol independence patch.
svn path=/trunk/; revision=4280
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 6517be76..7c5dad3a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ SUBDIRS= m4 po
AUTOMAKE_OPTIONS= foreign no-dist-gzip dist-bzip2
AM_CFLAGS= @CEFLAGS@
-AM_CPPFLAGS= @CPFLAGS@
+AM_CPPFLAGS= @CPFLAGS@ -I$(srcdir)/libesmtp
AM_LDFLAGS= @LDEFLAGS@
ACLOCAL_AMFLAGS= -I m4 -I m4-local
AM_YFLAGS= -d
@@ -23,7 +23,8 @@ localedir= $(datadir)/locale
DEFS= @DEFS@ -DLOCALEDIR=\"$(localedir)\"
noinst_LIBRARIES= libfm.a
-libfm_a_SOURCES= xmalloc.c base64.c rfc822.c report.c rfc2047e.c servport.c
+libfm_a_SOURCES= xmalloc.c base64.c rfc822.c report.c rfc2047e.c servport.c \
+ libesmtp/gethostbyname.h libesmtp/gethostbyname.c
libfm_a_LIBADD= $(EXTRAOBJ)
libfm_a_DEPENDENCIES= $(EXTRAOBJ)
LDADD = libfm.a @LIBINTL@ $(LIBOBJS)
@@ -53,7 +54,9 @@ fetchmail_SOURCES= fetchmail.h getopt.h \
opie.c rpa.c interface.c netrc.c \
unmime.c conf.c checkalias.c smbdes.c smbencrypt.c \
smbmd4.c smbutil.c lock.c \
- rcfile_l.l rcfile_y.y ucs/norm_charmap.c
+ rcfile_l.l rcfile_y.y ucs/norm_charmap.c \
+ libesmtp/getaddrinfo.h libesmtp/getaddrinfo.c \
+ KAME/getnameinfo.c
check_PROGRAMS += rfc822 unmime netrc rfc2047e mxget