aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2007-03-18 01:24:22 +0000
committerMatthias Andree <matthias.andree@gmx.de>2007-03-18 01:24:22 +0000
commit321d61b215169346708da3ad2b74711996771635 (patch)
tree2d214a6b6ea2a9e02dd15261fad62af157f7d2cf /Makefile.am
parenta59128a9369bc21df6485ddd548964a7345d1008 (diff)
downloadfetchmail-321d61b215169346708da3ad2b74711996771635.tar.gz
fetchmail-321d61b215169346708da3ad2b74711996771635.tar.bz2
fetchmail-321d61b215169346708da3ad2b74711996771635.zip
Strengthen APOP a bit (validate RFC-822 syntax) in order to fend off
Leurent-style MITM attacks which are based on MD5 and APOP weaknesses. svn path=/branches/BRANCH_6-3/; revision=5057
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 00c5a3e6..28338b7c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,7 +39,7 @@ libfm_a_SOURCES= xmalloc.c base64.c rfc822.c report.c rfc2047e.c \
servport.c ntlm.h smbbyteorder.h smbdes.h smbmd4.h \
smbencrypt.h smbdes.c smbencrypt.c smbmd4.c smbutil.c \
libesmtp/gethostbyname.h libesmtp/gethostbyname.c \
- smbtypes.h fm_getaddrinfo.c tls.c
+ smbtypes.h fm_getaddrinfo.c tls.c rfc822valid.c
libfm_a_LIBADD= $(EXTRAOBJ)
libfm_a_DEPENDENCIES= $(EXTRAOBJ)
LDADD = libfm.a @LIBINTL@ $(LIBOBJS)
@@ -100,11 +100,13 @@ if NEED_GETADDRINFO
fetchmail_SOURCES += libesmtp/getaddrinfo.h libesmtp/getaddrinfo.c
endif
-check_PROGRAMS += rfc822 unmime netrc rfc2047e mxget
+check_PROGRAMS += rfc822 unmime netrc rfc2047e mxget rfc822valid
rfc2047e_CFLAGS= -DTEST
-rfc822_CFLAGS= -DMAIN
+rfc822valid_CFLAGS= -DTEST
+
+rfc822_CFLAGS= -DMAIN
unmime_SOURCES= unmime.c
unmime_CFLAGS= -DSTANDALONE -DHAVE_CONFIG_H -I$(builddir)