aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2010-08-27 21:33:41 +0200
committerMatthias Andree <matthias.andree@gmx.de>2010-08-27 21:35:24 +0200
commit2bae8712f8f3414167025c1faf9f118fb313a409 (patch)
tree148c2c30b8786a5e39b6e7119a61d6ed1d0e5a90 /Makefile.am
parent8d10076819e41620147013c8446809c085b1e0bf (diff)
downloadfetchmail-2bae8712f8f3414167025c1faf9f118fb313a409.tar.gz
fetchmail-2bae8712f8f3414167025c1faf9f118fb313a409.tar.bz2
fetchmail-2bae8712f8f3414167025c1faf9f118fb313a409.zip
Add self-test for X.509 name matching.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 6a12786b..3f8f8ea0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,7 +46,7 @@ DEPENDENCIES= libfm.a $(LIBOBJS)
check_PROGRAMS=
-TESTS= t.smoke t.validate-xhtml
+TESTS= t.smoke t.validate-xhtml t.x509_name_match
TESTS_ENVIRONMENT= srcdir="$(srcdir)" LC_ALL=C TZ=UTC SHELL="$(SHELL)" $(SHELL)
if NEED_TRIO
@@ -99,7 +99,8 @@ if NEED_GETADDRINFO
fetchmail_SOURCES += libesmtp/getaddrinfo.h libesmtp/getaddrinfo.c
endif
-check_PROGRAMS += rfc822 unmime netrc rfc2047e mxget rfc822valid
+check_PROGRAMS += rfc822 unmime netrc rfc2047e mxget rfc822valid \
+ x509_name_match
rfc2047e_CFLAGS= -DTEST
@@ -107,6 +108,8 @@ rfc822valid_CFLAGS= -DTEST
rfc822_CFLAGS= -DMAIN
+x509_name_match_CFLAGS= -DTEST
+
unmime_SOURCES= unmime.c
unmime_CFLAGS= -DSTANDALONE -DHAVE_CONFIG_H -I$(builddir)