aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2021-01-30 10:52:19 +0100
committerMatthias Andree <matthias.andree@gmx.de>2021-01-30 10:52:19 +0100
commit0486b4d689e2c9a71e367297ffc340469253332b (patch)
treedc6429130f457a31f496ad90e2865bf5ecccba7d /Makefile.am
parent7349f1241ab59a26b95117823981cf135c553add (diff)
downloadfetchmail-0486b4d689e2c9a71e367297ffc340469253332b.tar.gz
fetchmail-0486b4d689e2c9a71e367297ffc340469253332b.tar.bz2
fetchmail-0486b4d689e2c9a71e367297ffc340469253332b.zip
tls-aux.c: add helper to obtain default cert paths
...and compile it as standalone test program. After "make check", you can check t.tls-aux.log in the build area for the defaults. Note that environment overrides can be made, see SSL_CTX_set_default_verify_paths(3) or, for instance, https://www.openssl.org/docs/man1.1.1/man3/SSL_CTX_set_default_verify_paths.html OpenSSL 3.x may ship an openssl-env(7) manual page.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 083c5340..d7d0320c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,7 +47,7 @@ DEPENDENCIES= libfm.a $(LIBOBJS)
check_PROGRAMS=
-TESTS= t.smoke t.validate-xhtml10 t.validate-xhtml t.x509_name_match t.realpath
+TESTS= t.smoke t.validate-xhtml10 t.validate-xhtml t.x509_name_match t.realpath t.tls-aux
LOG_COMPILER= env LC_ALL=C TZ=UTC $(SHELL)
if NEED_TRIO
@@ -102,8 +102,10 @@ if NEED_GETADDRINFO
fetchmail_SOURCES += libesmtp/getaddrinfo.h libesmtp/getaddrinfo.c
endif
+tls_aux_SOURCES = tls-aux.c
+
check_PROGRAMS += rfc822 unmime netrc rfc2047e mxget rfc822valid \
- x509_name_match fm_realpath
+ x509_name_match fm_realpath tls-aux
fm_realpath_CFLAGS= -DTEST
@@ -113,6 +115,8 @@ rfc822valid_CFLAGS= -DTEST
rfc822_CFLAGS= -DMAIN
+tls_aux_CFLAGS= -DTEST
+
x509_name_match_CFLAGS= -DTEST
unmime_SOURCES= unmime.c