diff options
author | Eric S. Raymond <esr@thyrsus.com> | 1996-12-30 21:02:16 +0000 |
---|---|---|
committer | Eric S. Raymond <esr@thyrsus.com> | 1996-12-30 21:02:16 +0000 |
commit | eb86f615066e71738f8f9ab924118e789380c873 (patch) | |
tree | eeb5a1a9a2b33781b104e7cdd562aca819be9428 | |
parent | f7b666e1d4d1afd76f0696324f3d60e7de10de19 (diff) | |
download | fetchmail-eb86f615066e71738f8f9ab924118e789380c873.tar.gz fetchmail-eb86f615066e71738f8f9ab924118e789380c873.tar.bz2 fetchmail-eb86f615066e71738f8f9ab924118e789380c873.zip |
Cleaned up ticker dots code.
svn path=/trunk/; revision=708
-rw-r--r-- | NEWS | 4 | ||||
-rw-r--r-- | configure.in | 4 | ||||
-rw-r--r-- | driver.c | 1 | ||||
-rw-r--r-- | fetchmail.h | 1 |
4 files changed, 10 insertions, 0 deletions
@@ -14,6 +14,10 @@ features -- bugs -- +* Fixed a minor bug introduced into From handling by 2.6. + +There are 169 people on the fetchmail-friends list. + ------------------------------------------------------------------------------ fetchmail-2.6 (Fri Dec 27 12:42:56 EST 1996) diff --git a/configure.in b/configure.in index 6dea56c5..b8950a8e 100644 --- a/configure.in +++ b/configure.in @@ -81,6 +81,10 @@ if test $opt_enable_stdio = unset; then *-*-*freebsd*) AC_DEFINE(USE_STDIO) ;; + case $host in + *-*-*linux*) + AC_DEFINE(USE_STDIO) + ;; esac elif test $opt_enable_stdio = yes; then AC_DEFINE(USE_STDIO) @@ -874,6 +874,7 @@ const struct method *proto; /* protocol method table */ tagnum = 0; tag[0] = '\0'; /* nuke any tag hanging out from previous query */ ok = 0; + error_init(poll_interval == 0 && !logfile); /* set up the server-nonresponse timeout */ sigsave = signal(SIGVTALRM, vtalarm_handler); diff --git a/fetchmail.h b/fetchmail.h index 905bc211..7b194c24 100644 --- a/fetchmail.h +++ b/fetchmail.h @@ -164,6 +164,7 @@ extern int smtp_response; /* numeric value of SMTP response code */ /* prototypes for globally callable functions */ #if defined(HAVE_STDARG_H) +void error_init(int foreground); void error (int status, int errnum, const char *format, ...); void error_build (const char *format, ...); void error_complete (int status, int errnum, const char *format, ...); |