aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-05-21 19:07:15 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-05-21 19:07:15 +0000
commite7af36d2f3afb074ce93552b9e49a873129f6149 (patch)
tree670ac993c9a85bed0283df3b8663089f2fcccbbb
parente21d106c1f2aec2f524e5a923506df2e4f80b208 (diff)
downloadfetchmail-e7af36d2f3afb074ce93552b9e49a873129f6149.tar.gz
fetchmail-e7af36d2f3afb074ce93552b9e49a873129f6149.tar.bz2
fetchmail-e7af36d2f3afb074ce93552b9e49a873129f6149.zip
Remove GNU make dependencies.
svn path=/trunk/; revision=3321
-rw-r--r--Makefile.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/Makefile.in b/Makefile.in
index 339bd2a9..6e8418ba 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -127,10 +127,10 @@ fetchmail: $(objs) @INTLDEPS@
intl:
@INTLDEPS@: dummy
- $(MAKE) -C intl
+ cd intl; $(MAKE)
po: dummy
- $(MAKE) -C po
+ cd po; $(MAKE)
dummy:
@@ -173,29 +173,29 @@ install:
rm -f $(DESTDIR)$(mandir)/fetchmailconf.$(manext)
cd $(DESTDIR)$(mandir) && ln -s fetchmail.$(manext) fetchmailconf.$(manext)
@echo "Installing language catalogs..."
- -$(MAKE) -C intl install
- $(MAKE) -C po install
+ -cd intl; $(MAKE) install
+ cd po; $(MAKE) install
uninstall:
rm -f $(DESTDIR)$(bindir)/fetchmail $(DESTDIR)$(bindir)/fetchmailconf
rm -f $(DESTDIR)$(mandir)/fetchmail.$(manext) $(DESTDIR)$(mandir)/fetchmailconf.$(manext)
- -$(MAKE) -C intl uninstall
- $(MAKE) -C po uninstall
+ -cd intl; $(MAKE) uninstall
+ cd po; $(MAKE) uninstall
.PHONY: clean realclean distclean mostlyclean
clean:
- -$(MAKE) -C intl clean
+ -cd intl; $(MAKE) clean
#work around braindamage in GNU gettext
-rm -f intl/libintl.h
- -$(MAKE) -C po clean
+ -cd po; $(MAKE) clean
-rm -f fetchmail *.o core fetchmail.dvi \
rcfile_l.c rcfile_y.h rcfile_y.c \
fetchmail.tar fetchmail.tar.gz \
netrc rfc822 unmime fetchmail-man.html
distclean: clean
- -$(MAKE) -C intl distclean
- -$(MAKE) -C po distclean
+ -cd intl; $(MAKE) distclean
+ -cd po; $(MAKE) distclean
-rm -f TAGS tags
# Can't do these, it messes up RPM build
#-rm -f config.h config.cache config.status config.log stamp-config