aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1997-07-01 16:54:08 +0000
committerEric S. Raymond <esr@thyrsus.com>1997-07-01 16:54:08 +0000
commite72637a2022c33425341ab26790d19f88d18fec5 (patch)
tree6e05468152b570260c6e3dbc5ed21b1c18144caa
parent197ed6c695bd3bf8040fe5df91ceece243d78a81 (diff)
downloadfetchmail-e72637a2022c33425341ab26790d19f88d18fec5.tar.gz
fetchmail-e72637a2022c33425341ab26790d19f88d18fec5.tar.bz2
fetchmail-e72637a2022c33425341ab26790d19f88d18fec5.zip
Some configuration cleanup.
svn path=/trunk/; revision=1133
-rw-r--r--Makefile.in3
-rw-r--r--alloca.c2
-rw-r--r--daemon.c2
-rw-r--r--etrn.c5
-rw-r--r--fetchmail.c2
-rw-r--r--getopt.c2
-rw-r--r--getopt1.c2
-rw-r--r--getpass.c3
-rw-r--r--imap.c2
-rw-r--r--interface.c2
-rw-r--r--md5c.c2
-rw-r--r--options.c2
-rw-r--r--pop2.c3
-rw-r--r--pop3.c2
-rw-r--r--rcfile_l.l2
-rw-r--r--rcfile_y.y2
-rw-r--r--report.c2
-rw-r--r--socket.c3
-rw-r--r--uid.c4
-rw-r--r--xmalloc.c2
20 files changed, 26 insertions, 23 deletions
diff --git a/Makefile.in b/Makefile.in
index 974a6b64..057b397a 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -106,9 +106,8 @@ fetchmail: $(objs)
rfc822: rfc822.c
gcc -DTESTMAIN -g rfc822.c -o rfc822
-# -I. is needed to find config.h in the build directory.
.c.o:
- $(CC) $(defines) -c -I. -I$(srcdir) $(CFLAGS) $< $(OUTPUT_OPTION)
+ $(CC) $(defines) -c -I$(srcdir) $(CFLAGS) $< $(OUTPUT_OPTION)
# lex rule
.l.o:
diff --git a/alloca.c b/alloca.c
index 7020f32c..ec432dfc 100644
--- a/alloca.c
+++ b/alloca.c
@@ -22,7 +22,7 @@
your main control loop, etc. to force garbage collection. */
#ifdef HAVE_CONFIG_H
-#include <config.h>
+#include "config.h"
#endif
#ifdef emacs
diff --git a/daemon.c b/daemon.c
index 2bf69682..985fe65b 100644
--- a/daemon.c
+++ b/daemon.c
@@ -4,7 +4,7 @@
* For license terms, see the file COPYING in this directory.
*/
-#include <config.h>
+#include "config.h"
#include <stdio.h>
#include <errno.h>
diff --git a/etrn.c b/etrn.c
index 5ccc0f86..6b6df343 100644
--- a/etrn.c
+++ b/etrn.c
@@ -14,6 +14,9 @@
#include "smtp.h"
#include "socket.h"
+#ifdef HAVE_GETHOSTBYNAME
+#include <netdb.h>
+
static int etrn_ok (int sock, char *argbuf)
/* parse command response */
{
@@ -187,4 +190,6 @@ int doETRN (struct query *ctl)
return(do_protocol(ctl, &etrn));
}
+#endif /* HAVE_GETHOSTBYNAME */
+
/* etrn.c ends here */
diff --git a/fetchmail.c b/fetchmail.c
index 28b82e96..d4edf85c 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -4,7 +4,7 @@
* For license terms, see the file COPYING in this directory.
*/
-#include <config.h>
+#include "config.h"
#include <stdio.h>
#include <ctype.h>
diff --git a/getopt.c b/getopt.c
index ecf0c34c..04524325 100644
--- a/getopt.c
+++ b/getopt.c
@@ -27,7 +27,7 @@
#endif
#ifdef HAVE_CONFIG_H
-#include <config.h>
+#include "config.h"
#endif
#if !defined (__STDC__) || !__STDC__
diff --git a/getopt1.c b/getopt1.c
index 4580211c..45e504b4 100644
--- a/getopt1.c
+++ b/getopt1.c
@@ -17,7 +17,7 @@
Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
#ifdef HAVE_CONFIG_H
-#include <config.h>
+#include "config.h"
#endif
#include "getopt.h"
diff --git a/getpass.c b/getpass.c
index 447a8f0c..f3d6d48f 100644
--- a/getpass.c
+++ b/getpass.c
@@ -10,7 +10,8 @@
***********************************************************************/
-#include <config.h>
+#include "config.h"
+
#include <stdio.h>
#include <signal.h>
#include <fcntl.h>
diff --git a/imap.c b/imap.c
index e3867af4..943dc284 100644
--- a/imap.c
+++ b/imap.c
@@ -5,7 +5,7 @@
* For license terms, see the file COPYING in this directory.
*/
-#include <config.h>
+#include "config.h"
#include <stdio.h>
#include <string.h>
#include <ctype.h>
diff --git a/interface.c b/interface.c
index 1dbc7d39..295bb3be 100644
--- a/interface.c
+++ b/interface.c
@@ -13,7 +13,7 @@
#ifdef linux
-#include <config.h>
+#include "config.h"
#include <stdio.h>
#include <string.h>
#if defined(STDC_HEADERS)
diff --git a/md5c.c b/md5c.c
index 43d85e68..92b5d44a 100644
--- a/md5c.c
+++ b/md5c.c
@@ -23,7 +23,7 @@ These notices must be retained in any copies of any part of this
documentation and/or software.
*/
-#include <config.h>
+#include "config.h"
#include "md5global.h"
#include "md5.h"
diff --git a/options.c b/options.c
index ff932f96..8e1e894f 100644
--- a/options.c
+++ b/options.c
@@ -4,7 +4,7 @@
* For license terms, see the file COPYING in this directory.
*/
-#include <config.h>
+#include "config.h"
#include <stdio.h>
#include <pwd.h>
diff --git a/pop2.c b/pop2.c
index 8615c59a..dbb37284 100644
--- a/pop2.c
+++ b/pop2.c
@@ -5,7 +5,8 @@
* For license terms, see the file COPYING in this directory.
*/
-#include <config.h>
+#include "config.h"
+
#ifdef POP2_ENABLE
#include <stdio.h>
#if defined(STDC_HEADERS)
diff --git a/pop3.c b/pop3.c
index ebc6f962..53c0f5c9 100644
--- a/pop3.c
+++ b/pop3.c
@@ -4,7 +4,7 @@
* For license terms, see the file COPYING in this directory.
*/
-#include <config.h>
+#include "config.h"
#include <stdio.h>
#include <string.h>
diff --git a/rcfile_l.l b/rcfile_l.l
index c1234fcf..581a7290 100644
--- a/rcfile_l.l
+++ b/rcfile_l.l
@@ -6,7 +6,7 @@
* For license terms, see the file COPYING in this directory.
*/
-#include <config.h>
+#include "config.h"
#include "fetchmail.h"
#include "rcfile_y.h"
diff --git a/rcfile_y.y b/rcfile_y.y
index decf6111..4b95d5f9 100644
--- a/rcfile_y.y
+++ b/rcfile_y.y
@@ -5,7 +5,7 @@
* For license terms, see the file COPYING in this directory.
*/
-#include <config.h>
+#include "config.h"
#include <stdio.h>
#include <sys/types.h>
#include <sys/file.h>
diff --git a/report.c b/report.c
index 45fba868..a1e6c7f1 100644
--- a/report.c
+++ b/report.c
@@ -23,7 +23,7 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. */
*/
#ifdef HAVE_CONFIG_H
-# include <config.h>
+# include "config.h"
#endif
#include <stdio.h>
diff --git a/socket.c b/socket.c
index 904f6f46..59c1f64f 100644
--- a/socket.c
+++ b/socket.c
@@ -4,8 +4,7 @@
* For license terms, see the file COPYING in this directory.
*/
-#include <config.h>
-
+#include "config.h"
#include <stdio.h>
#include <string.h>
#include <sys/types.h>
diff --git a/uid.c b/uid.c
index c531915a..d9650f1e 100644
--- a/uid.c
+++ b/uid.c
@@ -4,15 +4,13 @@
* For license terms, see the file COPYING in this directory.
*/
-#include <config.h>
+#include "config.h"
#include <stdio.h>
-
#if defined(STDC_HEADERS)
#include <stdlib.h>
#include <string.h>
#endif
-
#if defined(HAVE_UNISTD_H)
#include <unistd.h>
#endif
diff --git a/xmalloc.c b/xmalloc.c
index 8e085b0c..0ce09053 100644
--- a/xmalloc.c
+++ b/xmalloc.c
@@ -4,7 +4,7 @@
* For license terms, see the file COPYING in this directory.
*/
-#include <config.h>
+#include "config.h"
#include <stdio.h>
#include <errno.h>
#include <string.h>