aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2019-06-23 10:17:48 +0200
committerMatthias Andree <matthias.andree@gmx.de>2019-08-05 13:08:43 +0200
commite19fbae0fe0abe836a937a320275abbf1f9eac7a (patch)
treebaf2e463f7fcfbc0a38ef4792eca932c4a2f4d0c
parenta4240b8eb85c16109d2bb929535845272a195d7c (diff)
downloadfetchmail-e19fbae0fe0abe836a937a320275abbf1f9eac7a.tar.gz
fetchmail-e19fbae0fe0abe836a937a320275abbf1f9eac7a.tar.bz2
fetchmail-e19fbae0fe0abe836a937a320275abbf1f9eac7a.zip
Add git-check target from bogofilter.
This is meant to see if the git export contains all files required for bootstrapping, in order to find files that were not added before a commit.
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e0fb5c75..963d98a3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -232,11 +232,19 @@ dist-hook:
rsync: distdir $(srcdir)/.rsyncs
@( cat $(srcdir)/.rsyncs | sed -e 's}^}rsync -aH --delete-after $(PACKAGE)-$(VERSION)/ }; s/\($$\)/ \&/;' ; echo "wait" ) | $(SHELL) -x
-.PHONY: import-translations
+.PHONY: import-translations git-check
import-translations:
rsync -Lrtvz translationproject.org::tp/latest/fetchmail/ $(top_srcdir)/po
cd $(top_builddir)/po && $(MAKE) update-po
+git-check:
+ @set -x && if test -d $(PACKAGE)-$(VERSION)-export ; then chmod -R u+rwX $(PACKAGE)-$(VERSION)-export ; fi && \
+ rm -rf $(PACKAGE)-$(VERSION)-export && \
+ mkdir $(PACKAGE)-$(VERSION)-export && \
+ ( cd $(top_srcdir) && git archive --format=tar HEAD ) | tar -C $(PACKAGE)-$(VERSION)-export -xf - && \
+ cd $(PACKAGE)-$(VERSION)-export && chmod -R u+rwX . && autoreconf -i -f -s -v \
+ && mkdir _build && cd _build && ../configure && $(MAKE) distcheck
+
SUFFIXES = .html .txt
.txt.html:
asciidoc --unsafe -a toc -a data-uri -o $@ $< || { rm -f $@ ; exit 1 ; }