aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2003-07-17 19:15:52 +0000
committerEric S. Raymond <esr@thyrsus.com>2003-07-17 19:15:52 +0000
commitdf07e0a6aa4db813728d9fd49f2f6d564ed5e372 (patch)
treec40a386b481a24ffe131ba102eab203523dc59c5
parent4694ac11a985871948e703a2cafd5e1db03a3dd0 (diff)
downloadfetchmail-df07e0a6aa4db813728d9fd49f2f6d564ed5e372.tar.gz
fetchmail-df07e0a6aa4db813728d9fd49f2f6d564ed5e372.tar.bz2
fetchmail-df07e0a6aa4db813728d9fd49f2f6d564ed5e372.zip
Build openssl with Kerberos.
svn path=/trunk/; revision=3824
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 197a0410..d2b57ae9 100644
--- a/configure.in
+++ b/configure.in
@@ -599,9 +599,11 @@ then
fi
if test -r $with_ssl/include/openssl/ssl.h
then
- ### ssl.h found under openssl. Use openssl configuration preferentially
+ ### ssl.h found under openssl. Use openssl configuration preferentially,
+ ### In Red Hat 9, this file includes a reference to <krb5.h>, so we
+ ### force the Kerberos direcory onto the include path so it will build.
echo "Enabling OpenSSL support in $with_ssl"
- CEFLAGS="$CEFLAGS -I$with_ssl/include/openssl"
+ CEFLAGS="$CEFLAGS -I$with_ssl/include/openssl -I/usr/kerberos/include"
### OpenBSD comes with ssl headers
elif test -r /usr/include/ssl/ssl.h
then