aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2009-08-18 12:14:37 +0000
committerMatthias Andree <matthias.andree@gmx.de>2009-08-18 12:14:37 +0000
commitdaf6512a893fa61c9b8d4b8dc93c46e2a94e7f42 (patch)
tree8f2cb212f8716d2c5593bca83be19db1392fd833
parentab438eeb75c378da12af944a9525d497ae755e83 (diff)
downloadfetchmail-daf6512a893fa61c9b8d4b8dc93c46e2a94e7f42.tar.gz
fetchmail-daf6512a893fa61c9b8d4b8dc93c46e2a94e7f42.tar.bz2
fetchmail-daf6512a893fa61c9b8d4b8dc93c46e2a94e7f42.zip
Validate *.html documents as XHTML in 'make check'.
svn path=/branches/BRANCH_6-3/; revision=5420
-rw-r--r--Makefile.am6
-rwxr-xr-xt.validate-xhtml15
2 files changed, 18 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 49937ff5..54085387 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,8 +46,8 @@ DEPENDENCIES= libfm.a $(LIBOBJS)
check_PROGRAMS=
-TESTS= t.smoke
-TESTS_ENVIRONMENT= srcdir="@srcdir@" LC_ALL=C TZ=UTC
+TESTS= t.smoke t.validate-xhtml
+TESTS_ENVIRONMENT= srcdir="$(srcdir)" LC_ALL=C TZ=UTC SHELL="$(SHELL)"
if NEED_TRIO
noinst_LIBRARIES+= libtrio.a
@@ -175,7 +175,7 @@ EXTRA_DIST+= $(DISTDOCS) fetchmail.spec $(distdirs) ucs/README.svn \
m4/xsize.m4 \
m4-local/ac-archive-license.txt \
m4-local/ac_ma_search_package.m4 \
- t.smoke t.rc \
+ $(TESTS) t.rc \
dist-tools/html2txt \
dist-tools/manServer.pl \
Doxyfile
diff --git a/t.validate-xhtml b/t.validate-xhtml
new file mode 100755
index 00000000..e3271988
--- /dev/null
+++ b/t.validate-xhtml
@@ -0,0 +1,15 @@
+#! /bin/sh
+
+# This test script validates all *.html files as XHTML.
+
+set -e
+e=0
+fail=
+IFS=$(printf '\n\t')
+for i in "${srcdir}"/*.html ; do
+ xmllint --postvalid --noout "$i" || { e=1 ; fail="$i${fail:+" "}$fail" ; }
+done
+if [ $e != 0 ] ; then
+ echo >&2 ">>>>> Invalid XHTML in files: ${fail}."
+fi
+exit $e