aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1996-10-01 07:26:21 +0000
committerEric S. Raymond <esr@thyrsus.com>1996-10-01 07:26:21 +0000
commitd5b61e5277c6e290ad247100d7efd178b1886abd (patch)
tree330ff83cd94561c5238832e47668ca8bf5b6ba9f
parentaaeb3055402a95323d97a7807c0b92848afb0aa5 (diff)
downloadfetchmail-d5b61e5277c6e290ad247100d7efd178b1886abd.tar.gz
fetchmail-d5b61e5277c6e290ad247100d7efd178b1886abd.tar.bz2
fetchmail-d5b61e5277c6e290ad247100d7efd178b1886abd.zip
Make sure we inherit the version from the makefile.
svn path=/trunk/; revision=186
-rw-r--r--Makefile.in2
-rw-r--r--fetchmail.c5
2 files changed, 2 insertions, 5 deletions
diff --git a/Makefile.in b/Makefile.in
index 3a2a6a64..82134cb1 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -25,7 +25,7 @@ RANLIB = @RANLIB@
# NeXT 1.0a uses an old version of GCC, which required -D__inline=inline.
# See also `config.h'.
-defines = @DEFS@
+defines = -DRELEASE_ID=\"$(VERS)\" @DEFS@
# defines = -DHAVE_CONFIG_H -DQNX -DHAVE_UNISTD_H -DSTDC_HEADERS # QNX
# If your system needs extra libraries loaded in, define them here.
diff --git a/fetchmail.c b/fetchmail.c
index e31a3e49..bdd5d96c 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -38,9 +38,6 @@
#include "fetchmail.h"
-/* release info */
-#define RELEASE_TAG "1.0"
-
#ifdef HAVE_PROTOTYPES
/* prototypes for internal functions */
int showoptions (struct hostrec *queryctl);
@@ -341,7 +338,7 @@ struct hostrec *queryctl;
int showversioninfo()
{
- printf("This is fetchmail release %s\n",RELEASE_TAG);
+ printf("This is fetchmail release %s\n",RELEASE_ID);
}
/*********************************************************************