aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-03-24 17:57:22 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-03-24 17:57:22 +0000
commitd24d33989870127522d511ac03e440c11562f403 (patch)
treeccc89add8a76caa88525dc6cb16b12cdd31a94a7
parent87835075d4f5d1adf0e253861ae2bc3b15dfeae4 (diff)
downloadfetchmail-d24d33989870127522d511ac03e440c11562f403.tar.gz
fetchmail-d24d33989870127522d511ac03e440c11562f403.tar.bz2
fetchmail-d24d33989870127522d511ac03e440c11562f403.zip
More configuration fixes.
svn path=/trunk/; revision=3274
-rw-r--r--Makefile.in4
-rw-r--r--NEWS2
-rw-r--r--configure.in8
3 files changed, 8 insertions, 6 deletions
diff --git a/Makefile.in b/Makefile.in
index ecf168e8..3385ae48 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,7 @@
# So just uncomment all the lines marked QNX.
PACKAGE = fetchmail
-VERSION = 5.7.6
+VERSION = 5.7.7
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
@@ -271,7 +271,7 @@ docs = $(srcdir)/COPYING $(srcdir)/FEATURES $(srcdir)/fetchmail-features.html \
config = $(srcdir)/Makefile.in $(srcdir)/configure.in $(srcdir)/configure \
$(srcdir)/config.guess $(srcdir)/config.h.in $(srcdir)/config.sub \
$(srcdir)/acconfig.h $(srcdir)/aclocal.m4
-scripts = $(srcdir)/install.sh $(srcdir)/mkinstalldirs \
+scripts = $(srcdir)/install.sh $(srcdir)/missing.sh $(srcdir)/mkinstalldirs \
$(srcdir)/specgen.sh $(srcdir)/lsmgen.sh $(srcdir)/fetchmailconf
all = $(docs) $(config) $(srcs) $(parser) $(headers) $(extra) $(scripts) \
$(srcdir)/rh-config/* $(srcdir)/contrib/*[A-Za-uw-z] \
diff --git a/NEWS b/NEWS
index 72a91eca..01489364 100644
--- a/NEWS
+++ b/NEWS
@@ -2,6 +2,8 @@
(The `lines' figures total .c, .h, .l, and .y files under version control.)
+* More configure fixes -- include missing.h stub script in the distribution.
+
fetchmail-5.7.6 (Thu Mar 22 16:22:48 EST 2001), 20456 lines:
* Fix POP2 and POP3 password shrouding.
diff --git a/configure.in b/configure.in
index 0a2af8ec..d941e0e4 100644
--- a/configure.in
+++ b/configure.in
@@ -15,19 +15,19 @@ PACKAGE=`sed -n '/PACKAGE *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
VERSION=`sed -n '/VERSION *= *\(.*\)/s//\1/p' <$srcdir/Makefile.in`
AM_INIT_AUTOMAKE("$PACKAGE", "$VERSION")
-dnl Map autoconf, autoheader and aclocal to (/bin/true) if they are
+dnl Map autoconf, autoheader and aclocal to missing.sh if they are
dnl not available in the system, so as not to cause problems in
dnl Makefile.in. Be sure to fix this hack if we start supporting
dnl automake (Makefile.am).
if test -z "$AUTOCONF" ; then
- AUTOCONF=true
+ AUTOCONF="missing.sh autoconf"
fi
if test -z "$ACLOCAL" ; then
- ACLOCAL=true
+ ACLOCAL="missing.sh aclocal"
fi
if test -z "$AUTOHEADER" ; then
- AUTOHEADER=true
+ AUTOHEADER="missing.sh autoheader"
fi
AC_CANONICAL_HOST