aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2011-05-17 18:46:22 +0200
committerMatthias Andree <matthias.andree@gmx.de>2011-05-17 19:53:03 +0200
commitcee84bd4d4632d5fe844692a62bb437bcf76339c (patch)
tree108f50d12197f77aa30c7f2f8523993d5775412d
parentc7abefc668b1351ded4a58b93f78e84c62be1684 (diff)
downloadfetchmail-cee84bd4d4632d5fe844692a62bb437bcf76339c.tar.gz
fetchmail-cee84bd4d4632d5fe844692a62bb437bcf76339c.tar.bz2
fetchmail-cee84bd4d4632d5fe844692a62bb437bcf76339c.zip
Fix opie.h error handling.
Properly quote AC_MSG_ERROR argument.
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ae1db50b..533f239a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -458,8 +458,8 @@ AC_CACHE_SAVE
### use option --enable-opie to compile in the OPIE support
AC_ARG_ENABLE(opie,
[ --enable-opie support OTP through the OPIE library],
- [ AC_CHECK_HEADER(opie.h,, [AC_MSG_ERROR(cannot find <opie.h>, which is required for OPIE support.)])
- AC_CHECK_LIB(opie,opiegenerator,, [AC_MSG_ERROR(cannot find libopie, which is required for OPIE support.)])
+ [ AC_CHECK_HEADER(opie.h,, [AC_MSG_ERROR([cannot find <opie.h>, which is required for OPIE support.])])
+ AC_CHECK_LIB(opie,opiegenerator,, [AC_MSG_ERROR([cannot find libopie, which is required for OPIE support.])])
with_opie=$enableval],
[with_opie=no])
test "$with_opie" = "yes" && AC_DEFINE(OPIE_ENABLE,1,Define if you want OPIE support compiled in)