aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2006-03-14 12:04:32 +0000
committerMatthias Andree <matthias.andree@gmx.de>2006-03-14 12:04:32 +0000
commitcd5b84b42695f3a653df1e6692cf1bf5268a50f7 (patch)
tree775bf1b6cd060d4a6b1283f7b2935f8bb8329f06
parent9dc0b8bd674f71f8ee422b037dc409f2dd4f9487 (diff)
downloadfetchmail-cd5b84b42695f3a653df1e6692cf1bf5268a50f7.tar.gz
fetchmail-cd5b84b42695f3a653df1e6692cf1bf5268a50f7.tar.bz2
fetchmail-cd5b84b42695f3a653df1e6692cf1bf5268a50f7.zip
Disable SDPS if POP3 is disabled.
svn path=/branches/BRANCH_6-3/; revision=4735
-rw-r--r--NEWS1
-rw-r--r--configure.ac9
2 files changed, 9 insertions, 1 deletions
diff --git a/NEWS b/NEWS
index e932fd9f..344df4b5 100644
--- a/NEWS
+++ b/NEWS
@@ -51,6 +51,7 @@ fetchmail 6.3.3 (not yet released):
* ./configure --quiet is now quieter (no SSL and fallback-related output).
* fix bug in LMTP port validation (patch by Miloslav Trmac).
* Miloslav Trmac's patch (with minor changes) to fix char * sign consistency.
+* Warn and disable SDPS if POP3 is disabled to avoid compilation errors.
# CHANGES:
* --idle can now be specified on the command line, too.
diff --git a/configure.ac b/configure.ac
index 38551962..4fb2f4e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -350,7 +350,14 @@ AC_ARG_ENABLE(SDPS,
[ --enable-SDPS compile in SDPS protocol support],
[with_SDPS=$enableval],
[with_SDPS=no])
-test "$with_SDPS" = "yes" && AC_DEFINE(SDPS_ENABLE,1,Define if you want SDPS support compiled in)
+if test "$with_SDPS" = yes ; then
+ if test "$with_POP3" != yes ; then
+ AC_MSG_WARN([SDPS cannot be enabled with POP3 disabled. Disabling SDPS.])
+ with_SDPS=no
+ else
+ AC_DEFINE(SDPS_ENABLE,1,Define if you want SDPS support compiled in)
+ fi
+fi
### use option --enable-opie to compile in the OPIE support
AC_ARG_ENABLE(opie,