aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1996-12-05 04:30:31 +0000
committerEric S. Raymond <esr@thyrsus.com>1996-12-05 04:30:31 +0000
commitc714471f650de665f03591e2c5652d2831f04684 (patch)
treec60e8197581b35f6edcaaac223abfff7a8da9109
parent5358c65d297b4db355e10fece2ac942ac8c24b74 (diff)
downloadfetchmail-c714471f650de665f03591e2c5652d2831f04684.tar.gz
fetchmail-c714471f650de665f03591e2c5652d2831f04684.tar.bz2
fetchmail-c714471f650de665f03591e2c5652d2831f04684.zip
Autocinfigure for herror.
svn path=/trunk/; revision=601
-rw-r--r--configure.in2
-rw-r--r--fetchmail.c2
2 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a3935000..9e40d26c 100644
--- a/configure.in
+++ b/configure.in
@@ -70,7 +70,7 @@ dnl All AC_CHECK_FUNCs must precede the following AC_SUBSTs
AC_SUBST(EXTRASRC)
AC_SUBST(EXTRAOBJ)
-AC_CHECK_FUNCS(tcsetattr stty setsid seteuid gethostbyname res_search)
+AC_CHECK_FUNCS(tcsetattr stty setsid seteuid gethostbyname res_search herror)
dnl AC_FUNC_SETVBUF_REVERSED
diff --git a/fetchmail.c b/fetchmail.c
index 539da0e7..83ce10ef 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -343,8 +343,10 @@ int main (int argc, char **argv)
if (errno == ENETUNREACH)
break; /* go to sleep */
}
+#ifdef HAVE_HERROR /* NEXTSTEP doesn't */
else
herror("DNS error");
+#endif /* HAVE_HERROR */
continue;
}
else