aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2006-05-14 21:28:58 +0000
committerMatthias Andree <matthias.andree@gmx.de>2006-05-14 21:28:58 +0000
commitbbe00c06f9d7ab6e4d7be2fd4fae85fc2485c399 (patch)
tree5c6e0c354b44fca8e4c1649eeb63f296dd7498aa
parent88ee8504f34ab985f51632795d8af730e6158fd6 (diff)
downloadfetchmail-bbe00c06f9d7ab6e4d7be2fd4fae85fc2485c399.tar.gz
fetchmail-bbe00c06f9d7ab6e4d7be2fd4fae85fc2485c399.tar.bz2
fetchmail-bbe00c06f9d7ab6e4d7be2fd4fae85fc2485c399.zip
Improve --with-gssapi auto detection for /usr-based GSSAPI installs.
Fix --with-gssapi builds for NetBSD 3.0. svn path=/branches/BRANCH_6-3/; revision=4834
-rw-r--r--NEWS2
-rw-r--r--configure.ac10
2 files changed, 10 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 004e6d27..71d4173a 100644
--- a/NEWS
+++ b/NEWS
@@ -67,6 +67,8 @@ fetchmail 6.3.5 (not yet released):
* Fix des_pcbc_encrypt compile warnings in kerberos.c line 246.
* If krb5-config provides gssapi library information, use that rather than
guessing.
+* Improve --with-gssapi auto detection for /usr-based GSSAPI installs.
+* Fix --with-gssapi builds for NetBSD 3.0.
# CHANGES:
* Rename all fetchmail-internal lock_* functions to fm_lock_*. Obsoletes
diff --git a/configure.ac b/configure.ac
index c6078d57..646f9768 100644
--- a/configure.ac
+++ b/configure.ac
@@ -732,10 +732,16 @@ then
if test -n "$nogss"
then
# -lgss not found
- if test -f "$with_gssapi/include/roken.h"
+ if test "$with_gssapi" = yes ; then
+ with_gssapi=/usr
+ fi
+ if test -f "$with_gssapi/include/roken.h" -o -f "$with_gssapi/include/krb5/roken.h"
then
# have roken.h, assume Heimdal
- LIBS="$LIBS -lkrb5 -lasn1 -ldes -lroken -ldb -ldl"
+ case `uname` in
+ NetBSD) LIBS="$LIBS -lkrb5" ;;
+ *) LIBS="$LIBS -lkrb5 -lasn1 -ldes -lroken -ldb -ldl" ;;
+ esac
AC_CHECK_LIB(gssapi, gss_init_sec_context,LIBS="$LIBS -lgssapi",
AC_MSG_ERROR([could not find libgssapi which is needed for GSSAPI support]), )
AC_DEFINE(HEIMDAL)