diff options
author | Matthias Andree <matthias.andree@gmx.de> | 2010-05-17 21:10:16 +0200 |
---|---|---|
committer | Matthias Andree <matthias.andree@gmx.de> | 2010-05-17 21:10:16 +0200 |
commit | bb67b781f9b26a06f3f66a9db8b297920467d0db (patch) | |
tree | dc4937db5d35b7b03187b611fdb90e490a9ca8b8 | |
parent | 233bbfa928e1bcf8727247ebbcfe307c110866b3 (diff) | |
download | fetchmail-bb67b781f9b26a06f3f66a9db8b297920467d0db.tar.gz fetchmail-bb67b781f9b26a06f3f66a9db8b297920467d0db.tar.bz2 fetchmail-bb67b781f9b26a06f3f66a9db8b297920467d0db.zip |
Fix MD5* library pickup.
Avoid picking up libmd5, which fails if libwww is installed because libmd5
uses "long" rather than fixed-width types. This fails on non-32-bit machines.
Only probe libmd if md5.h is found.
To fix Gentoo Bug #319283, reported by Karl Hakimian.
-rw-r--r-- | NEWS | 4 | ||||
-rw-r--r-- | configure.ac | 12 |
2 files changed, 13 insertions, 3 deletions
@@ -58,6 +58,10 @@ fetchmail-6.3.18 (not yet released): * Fetchmail would warn about insecure SSL/TLS connections even if a matching --sslfingerprint was specified. This is an omission from a SSL usability change made in 6.3.17. Fixes Debian Bug#580796 reported by Roland Stigge. +* Fetchmail 6.3.15, 6.3.16, and 6.3.17 would pick up libmd5 to obtain MD5* + functions. This fails if, for instance, libmd5.so was installed as part of + libwww on machines where long isn't 32-bits. Fixes Gentoo Bug #319283, + reported - including the crucial hint to libwww - by Karl Hakimian. # KNOWN BUGS AND WORKAROUNDS: (this section floats upwards through the NEWS file so it stays with the diff --git a/configure.ac b/configure.ac index 2ff315f1..943eb3e4 100644 --- a/configure.ac +++ b/configure.ac @@ -171,9 +171,15 @@ dnl [LIBS="$LIBS -lintl"]) AC_REPLACE_FUNCS([strstr strcasecmp memmove stpcpy strlcpy strlcat]) -AC_SEARCH_LIBS(MD5Init, [md5 md], [], - [AC_LIBSOURCE(md5c.c) - EXTRAOBJ="$EXTRAOBJ md5c.\$(OBJEXT)"]) +have_md5=no +if test "$ac_cv_header_md5_h" != no ; then + AC_SEARCH_LIBS(MD5Init, [md], [have_md5=yes]) +fi + +if test "$have_md5" != yes ; then + AC_LIBSOURCE(md5c.c) + EXTRAOBJ="$EXTRAOBJ md5c.\$(OBJEXT)" +fi AC_CHECK_FUNC(getopt_long, [], [AC_LIBSOURCES([getopt.c, getopt1.c]) |