aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-09-26 14:32:49 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-09-26 14:32:49 +0000
commitb04887513f9f1ddbe509ec67f3dd812612f135a5 (patch)
treee9c47af68b0c0718c9855d7e6a9babbf637da0b3
parent2e4e5a1af29d5ce749b90f33db8153c81c6936bf (diff)
downloadfetchmail-b04887513f9f1ddbe509ec67f3dd812612f135a5.tar.gz
fetchmail-b04887513f9f1ddbe509ec67f3dd812612f135a5.tar.bz2
fetchmail-b04887513f9f1ddbe509ec67f3dd812612f135a5.zip
Ready to ship.
svn path=/trunk/; revision=3491
-rw-r--r--Makefile.in2
-rw-r--r--NEWS6
-rw-r--r--configure.in10
-rw-r--r--fetchmail.c2
-rw-r--r--options.c8
5 files changed, 25 insertions, 3 deletions
diff --git a/Makefile.in b/Makefile.in
index fe3e14c2..5226e45b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,7 @@
# So just uncomment all the lines marked QNX.
PACKAGE = fetchmail
-VERSION = 5.9.1
+VERSION = 5.9.2
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
diff --git a/NEWS b/NEWS
index 28739859..3cbb5e97 100644
--- a/NEWS
+++ b/NEWS
@@ -2,6 +2,12 @@
(The `lines' figures total .c, .h, .l, and .y files under version control.)
+* Enable code to build on Solaris again (long options won't work).
+* Move Hesiod lookups to just before DNS lookups.
+* Make sure the SICHLD handler is called when we run detached.
+* Make kerberos5 in OpenBSD (Federico Schwindt <fgsch@olimpo.com.br>).
+* Added FAQ item X8 on why mail sometimes gets an extra ) appended.
+
fetchmail-5.9.1 (Mon Sep 24 19:01:57 EDT 2001), 21120 lines:
* Make -D short option for --smtpaddress active again.
diff --git a/configure.in b/configure.in
index e893585b..710a93fc 100644
--- a/configure.in
+++ b/configure.in
@@ -389,6 +389,15 @@ directory],
[
if test "$with_kerberos5" != "no"
then
+# Check for a OpenBSD special case
+if test "$with_kerberos5" = "yes" && ( test `uname` = "OpenBSD" )
+then
+ AC_CHECKING([kerberosV for OpenBSD])
+ AC_DEFINE(HEIMDAL)
+ AC_DEFINE(KERBEROS_V5)
+ CEFLAGS="$CEFLAGS -I/usr/include/kerberosV"
+ LIBS="$LIBS -lasn1 -lkrb5 -lcom_err"
+else
if test "$with_kerberos5" != "yes"
then
LDEFLAGS="$LDEFLAGS -L${with_kerberos5}/lib"
@@ -446,6 +455,7 @@ then
AC_ERROR([Kerberos 5 libraries not found])
fi
fi
+fi
]) dnl --with-kerberos5=DIR
### use option --with-kerberos=DIR to point at a Kerberos 4 directory
diff --git a/fetchmail.c b/fetchmail.c
index 2e8cd94f..89984e25 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -1035,11 +1035,13 @@ static int load_params(int argc, char **argv, int optind)
DEFAULT(ctl->sslcertck, FALSE);
#endif
DEFAULT(ctl->server.checkalias, FALSE);
+#ifndef SSL_ENABLE
if (ctl->use_ssl)
{
report(stderr, GT_("SSL support is not compiled in.\n"));
exit(PS_SYNTAX);
}
+#endif /* SSL_ENABLE */
#undef DEFAULT
/*
diff --git a/options.c b/options.c
index cfe74bbd..c51e9d72 100644
--- a/options.c
+++ b/options.c
@@ -276,9 +276,13 @@ struct query *ctl; /* option record to be initialized */
ctl->smtp_socket = -1;
while (!errflag &&
+#ifdef HAVE_GETOPTLONG
(c = getopt_long(argc,argv,shortoptions,
- longoptions,&option_index)) != -1) {
-
+ longoptions, &option_index)) != -1)
+#else
+ (c = getopt(argc, argv, shortoptions)) != -1)
+#endif
+ {
switch (c) {
case 'V':
case LA_VERSION: