aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1997-06-02 03:05:53 +0000
committerEric S. Raymond <esr@thyrsus.com>1997-06-02 03:05:53 +0000
commitb0338391d385f9be0d5b64565ca269c07a208baf (patch)
tree4c3719a0359968086e50977e907c7300742fc7ad
parent3c591e354e5216a8c2dd149f020f82ecd29e9b69 (diff)
downloadfetchmail-b0338391d385f9be0d5b64565ca269c07a208baf.tar.gz
fetchmail-b0338391d385f9be0d5b64565ca269c07a208baf.tar.bz2
fetchmail-b0338391d385f9be0d5b64565ca269c07a208baf.zip
Add exim 501 response.
svn path=/trunk/; revision=1055
-rw-r--r--Makefile.in2
-rw-r--r--NEWS3
-rw-r--r--README13
-rw-r--r--driver.c5
4 files changed, 14 insertions, 9 deletions
diff --git a/Makefile.in b/Makefile.in
index fac4dc90..4a612887 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -78,7 +78,7 @@ CTAGS = ctags -tw
protobjs = rcfile_y.o rcfile_l.o socket.o getpass.o pop2.o pop3.o imap.o \
etrn.o fetchmail.o options.o daemon.o smtp.o driver.o rfc822.o \
- xmalloc.o uid.o mxget.o md5c.o md5ify.o interface.o netrc.o base64.c \
+ xmalloc.o uid.o mxget.o md5c.o md5ify.o interface.o netrc.o base64.o \
error.o
objs = $(protobjs) $(extras) $(EXTRAOBJ)
diff --git a/NEWS b/NEWS
index 24f241e9..9a677358 100644
--- a/NEWS
+++ b/NEWS
@@ -28,6 +28,9 @@ pl 3.9.7 ():
* Complain and die if user tries to start fetchmail with options while a
background fetchmail is running.
* Various installation headaches are gone, INSTALL edited accordingly.
+* Treat exim's 501 antispam response as equivalent to 571. Note: this
+ is temporary. The right thing is to get exim to return 571; I'm
+ working on it.
There are 257 people on the fetchmail-friends list.
diff --git a/README b/README
index 5ecf2de5..962701c7 100644
--- a/README
+++ b/README
@@ -1,14 +1,15 @@
fetchmail README
-fetchmail is a free, full-featured, robust, well-documented POP2, POP3, RPOP,
-APOP, KPOP, and IMAP batch mail retrieval/forwarding utility intended to be
-used over on-demand TCP/IP links (such as SLIP or PPP connections).
-It retrieves mail from remote mail servers and forwards it to your
-local (client) machine's delivery system, so it can then be be read by
+fetchmail is a free, full-featured, robust, well-documented
+remote mail retrieval and forwarding utility intended to be used over
+on-demand TCP/IP links (such as SLIP or PPP connections). It supports
+POP2, POP3, RPOP, APOP, KPOP, all flavors of IMAP, and ESMTP ETRN. It
+retrieves mail from remote mail servers and forwards it to your local
+(client) machine's delivery system, so it can then be be read by
normal mail user agents such as elm(1) or Mail(1).
The fetchmail code was developed under Linux, but has also been
-extensively tested under 4.4BSD, Solaris and NEXTSTEP. It should be
+extensively tested under 4.4BSD, AIX, Solaris and NEXTSTEP. It should be
readily portable to other Unix variants (it uses GNU autoconf). It
has also been ported to QNX; to build under QNX, see the header
comments in the Makefile.
diff --git a/driver.c b/driver.c
index b469e4e5..14700a52 100644
--- a/driver.c
+++ b/driver.c
@@ -808,7 +808,7 @@ char *realname; /* real name of host */
{
int smtperr = atoi(smtp_response);
- if (smtperr >= 400 && smtperr != 571)
+ if (smtperr >= 400 && smtperr != 571 || smtperr != 501)
error(0, -1, "SMTP error: %s", smtp_response);
/*
@@ -823,7 +823,8 @@ char *realname; /* real name of host */
switch (smtperr)
{
- case 571: /* unsolicited email refused */
+ case 571: /* unsolicited email refused */
+ case 501: /* exim's antispam response (temporary) */
/*
* SMTP listener explicitly refuses to deliver
* mail coming from this address, probably due