aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2002-06-07 14:49:34 +0000
committerEric S. Raymond <esr@thyrsus.com>2002-06-07 14:49:34 +0000
commitae4422381e78b2541118bf04909813c51a54b147 (patch)
treea3768e8707a7ff07acd2be39eb4e5d316d26a543
parent020ac3168772c3fef1fe5240717cb14273f345c8 (diff)
downloadfetchmail-ae4422381e78b2541118bf04909813c51a54b147.tar.gz
fetchmail-ae4422381e78b2541118bf04909813c51a54b147.tar.bz2
fetchmail-ae4422381e78b2541118bf04909813c51a54b147.zip
sendmail -i improvement.
svn path=/trunk/; revision=3638
-rw-r--r--NEWS5
-rw-r--r--configure.in13
-rw-r--r--fetchmail.c7
3 files changed, 17 insertions, 8 deletions
diff --git a/NEWS b/NEWS
index c1b4bcfe..6257912b 100644
--- a/NEWS
+++ b/NEWS
@@ -3,7 +3,10 @@
(The `lines' figures total .c, .h, .l, and .y files under version control.)
* Cygwin port fixes for socket.c.
-* Matthias Andree's patches to clean up xmalloc types abd improve distclean.
+* Matthias Andree's patches to
+ (a) clean up xmalloc types,
+ (b) improve distclean,
+ (c) use sendmail -i in configure.in and dump the fallback configuration.
fetchmail-5.9.12 (Tue Jun 4 14:57:47 EDT 2002), 21669 lines:
diff --git a/configure.in b/configure.in
index ac3b338e..05a37097 100644
--- a/configure.in
+++ b/configure.in
@@ -243,7 +243,7 @@ case "$enable_fallback" in
AC_ERROR([Sendmail selected as fallback, but not found])
#not reached
fi
- AC_DEFINE_UNQUOTED(FALLBACK_MDA, "$sendmail %T")
+ AC_DEFINE_UNQUOTED(FALLBACK_MDA, "$sendmail -i %T")
echo "Will use $sendmail as fallback MDA."
;;
procmail) if test -z "$procmail" ; then
@@ -262,13 +262,12 @@ case "$enable_fallback" in
;;
no|unset) echo "Will not use a fallback MDA"
;;
- auto|yes|set) if test -n "$procmail" ; then
- AC_DEFINE_UNQUOTED(FALLBACK_MDA,"$procmail -d %T")
- echo "Will use $procmail as fallback MDA."
- elif test -n "$sendmail" ; then
- AC_DEFINE_UNQUOTED(FALLBACK_MDA,"$sendmail %T")
+ auto|yes|set) if test -n "$sendmail" ; then
+ AC_DEFINE_UNQUOTED(FALLBACK_MDA,"$sendmail -i %T")
echo "Will use $sendmail as fallback MDA."
- else echo "No fallback MDA available."
+ else
+ echo "No fallback MDA available. procmail and maildrop are not eligible"
+ echo "for automatic fallback MDA configuration for reliability reasons."
fi
;;
*) AC_ERROR([unkown value for --enable-fallback given: $enable_fallback])
diff --git a/fetchmail.c b/fetchmail.c
index fa7b4625..eabc25d4 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -223,6 +223,13 @@ int main(int argc, char **argv)
printf("+NLS");
#endif /* ENABLE_NLS */
putchar('\n');
+ fputs("Fallback MDA: ", stdout);
+#ifdef FALLBACK_MDA
+ fputs(FALLBACK_MDA, stdout);
+#else
+ fputs("(none)", stdout);
+#endif
+ putchar('\n');
fflush(stdout);
/* this is an attempt to help remote debugging */