diff options
author | Matthias Andree <matthias.andree@gmx.de> | 2005-07-03 18:10:14 +0000 |
---|---|---|
committer | Matthias Andree <matthias.andree@gmx.de> | 2005-07-03 18:10:14 +0000 |
commit | a92c8c212e2f1e014166cfb84751ea052035599e (patch) | |
tree | 91a539bcdf1828d97514f63aebbe42ec9679f6b4 | |
parent | 3df8580c347d80739ef27011b0732c4514b814c3 (diff) | |
download | fetchmail-a92c8c212e2f1e014166cfb84751ea052035599e.tar.gz fetchmail-a92c8c212e2f1e014166cfb84751ea052035599e.tar.bz2 fetchmail-a92c8c212e2f1e014166cfb84751ea052035599e.zip |
Fix reply_hack() type of third argument (int vs. size_t), by Miloslav Trmac.
svn path=/trunk/; revision=4069
-rw-r--r-- | NEWS | 2 | ||||
-rw-r--r-- | fetchmail.h | 2 | ||||
-rw-r--r-- | rfc822.c | 4 |
3 files changed, 5 insertions, 3 deletions
@@ -76,6 +76,8 @@ fetchmail 6.3.0 (not yet released officially): when username contains an @ and the envelope sender is null, Debian bug #272289 (Matthias Andree) * configure.ac cleanups by Miloslav Trmac (Matthias Andree) +* Miloslav Trmac's fix to reply_hack() type, for systems where + sizeof(int) != sizeof(size_t). (Matthias Andree) fetchmail-6.2.5 (Wed Oct 15 18:39:22 EDT 2003), 23079 lines: diff --git a/fetchmail.h b/fetchmail.h index 9ce7942e..337b8607 100644 --- a/fetchmail.h +++ b/fetchmail.h @@ -542,7 +542,7 @@ void stuff_warning(); void close_warning_by_mail(struct query *, struct msgblk *); /* rfc822.c: RFC822 header parsing */ -unsigned char *reply_hack(unsigned char *, const unsigned char *, int *); +unsigned char *reply_hack(unsigned char *, const unsigned char *, size_t *); unsigned char *nxtaddr(const unsigned char *); /* uid.c: UID support */ @@ -44,7 +44,7 @@ char *program_name = "rfc822"; unsigned char *reply_hack( unsigned char *buf /* header to be hacked */, const unsigned char *host /* server hostname */, - int *length) + size_t *length) /* hack message headers so replies will work properly */ { unsigned char *from, *cp, last_nws = '\0', *parens_from = NULL; @@ -393,7 +393,7 @@ unsigned char *nxtaddr(const unsigned char *hdr /* header to be parsed, NUL to c static void parsebuf(unsigned char *longbuf, int reply) { unsigned char *cp; - int dummy; + size_t dummy; if (reply) { |