aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1996-07-01 18:00:20 +0000
committerEric S. Raymond <esr@thyrsus.com>1996-07-01 18:00:20 +0000
commita7599402b2e4d8c5cef1da9fe12159640fd15812 (patch)
treed4550fd34a742393bcc50425d8fca151d2d451af
parent8dc48b649e2e0b8781a05d47a39c59713e5a1d33 (diff)
downloadfetchmail-a7599402b2e4d8c5cef1da9fe12159640fd15812.tar.gz
fetchmail-a7599402b2e4d8c5cef1da9fe12159640fd15812.tar.bz2
fetchmail-a7599402b2e4d8c5cef1da9fe12159640fd15812.zip
Fix a lexical-analyzer bug.
svn path=/trunk/; revision=23
-rw-r--r--Makefile.in2
-rw-r--r--NEWS2
-rw-r--r--rcfile_l.l4
3 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.in b/Makefile.in
index 8e94625a..2581b953 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -11,7 +11,7 @@ LDFLAGS = @LDFLAGS@
LEX = @LEX@
LEXFLAGS=
YACC = @YACC@
-YACCFLAGS=-d
+YACCFLAGS = -dt
# How to invoke ranlib. This is only used by the `glob' subdirectory.
RANLIB = @RANLIB@
diff --git a/NEWS b/NEWS
index 82378a77..b130a699 100644
--- a/NEWS
+++ b/NEWS
@@ -2,6 +2,8 @@
3.01:
+* Fixed a lexical analyzer bug in quoted-string processing.
+
* Fixed a bug in dump_options that cauded username to be displayed incorrectly.
* The lock assertion code was in the wrong place relative to the daemonize()
diff --git a/rcfile_l.l b/rcfile_l.l
index 1968b994..f5281f78 100644
--- a/rcfile_l.l
+++ b/rcfile_l.l
@@ -49,12 +49,12 @@ nofetchall { yylval.flag = -1; return KW_FETCHALL; }
(#.*)?\n { prc_lineno++; return KW_EOL; }
-[^ \t\r\n#]+ { yylval.sval = (char *) strdup(yytext); return PARAM_STRING; }
-\"[^\"]*\"` {
+\"[^\"]*\" {
yytext[strlen(yytext)-1] = '\0';
yylval.sval = (char *) strdup(yytext+1);
return PARAM_STRING;
}
+[^ \t\r\n#]+ { yylval.sval = (char *) strdup(yytext); return PARAM_STRING; }
[ \t\r]+ ; /* whitespace */