aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2005-11-21 09:54:12 +0000
committerMatthias Andree <matthias.andree@gmx.de>2005-11-21 09:54:12 +0000
commita2c28a2fbfbe30867a35af5a175dde7bb0d963e5 (patch)
tree74ee0d1c8e2882ba13ca8756fabae2b3e8a77b36
parent78e64b850ed72fcd097e70e73424bb1de1031eba (diff)
downloadfetchmail-a2c28a2fbfbe30867a35af5a175dde7bb0d963e5.tar.gz
fetchmail-a2c28a2fbfbe30867a35af5a175dde7bb0d963e5.tar.bz2
fetchmail-a2c28a2fbfbe30867a35af5a175dde7bb0d963e5.zip
Cleanup. Sunil Shetye.
svn path=/trunk/; revision=4469
-rwxr-xr-xspecgen.sh12
1 files changed, 6 insertions, 6 deletions
diff --git a/specgen.sh b/specgen.sh
index 47293c4b..ea9eff05 100755
--- a/specgen.sh
+++ b/specgen.sh
@@ -12,7 +12,9 @@ export LANG LC_TIME
cat <<EOF
# Note: Do not hack fetchmail.spec by hand -- it's generated by specgen.sh
-%define with_python 1
+
+# Set to 0 if you do not have python
+%define have_python 1
Name: fetchmail
Version: $1
@@ -106,7 +108,7 @@ almindelige mail klienter såsom mutt, elm, pine, (x)emacs/gnus,
eller mailx. Der medfølger også et interaktivt GUI-baseret
konfigurations-program, som kan bruges af almindelige brugere.
-%if %{with_python}
+%if %{have_python}
%package -n fetchmailconf
Summary: A GUI configurator for generating fetchmail configuration files
Summary(de): GUI-Konfigurator für fetchmail
@@ -145,8 +147,6 @@ GUI konfigurator do fetchmaila napisany w pythonie.
%setup -q
%build
-LDFLAGS="-s"
-export CFLAGS LDFLAGS
%configure --without-included-gettext --without-kerberos --with-ssl --enable-inet6
make
@@ -154,7 +154,7 @@ make
rm -rf \$RPM_BUILD_ROOT
make install-strip DESTDIR=\$RPM_BUILD_ROOT
-%if %{with_python}
+%if %{have_python}
mkdir -p \$RPM_BUILD_ROOT/usr/lib/rhs/control-panel
cp rh-config/*.{xpm,init} \$RPM_BUILD_ROOT/usr/lib/rhs/control-panel
mkdir -p \$RPM_BUILD_ROOT/etc/X11/wmconfig
@@ -177,7 +177,7 @@ rm -rf \$RPM_BUILD_ROOT
%attr(755, root, root) %{_bindir}/fetchmail
%attr(644,root,root) %{_datadir}/locale/*/LC_MESSAGES/fetchmail.mo
-%if %{with_python}
+%if %{have_python}
%files -n fetchmailconf
%defattr (644, root, root, 755)
%attr(644,root,root) /etc/X11/wmconfig/fetchmailconf