aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1996-11-01 17:34:44 +0000
committerEric S. Raymond <esr@thyrsus.com>1996-11-01 17:34:44 +0000
commit9ed32aae0cceb23373b55a319a3483728a1042d7 (patch)
tree8e5b16d949224ecd3bd0c7c1b760194de74d2761
parent6d77e3b3e9a420477e69ed84ede49ed3c983ac83 (diff)
downloadfetchmail-9ed32aae0cceb23373b55a319a3483728a1042d7.tar.gz
fetchmail-9ed32aae0cceb23373b55a319a3483728a1042d7.tar.bz2
fetchmail-9ed32aae0cceb23373b55a319a3483728a1042d7.zip
Header cleanup.
svn path=/trunk/; revision=463
-rw-r--r--configure.in4
-rw-r--r--daemon.c12
-rw-r--r--driver.c2
-rw-r--r--fetchmail.c15
-rw-r--r--options.c2
-rw-r--r--pop3.c2
-rw-r--r--smtp.c3
-rw-r--r--socket.c4
-rw-r--r--uid.c2
-rw-r--r--xmalloc.c1
10 files changed, 13 insertions, 34 deletions
diff --git a/configure.in b/configure.in
index 2c5f573d..ee435b1d 100644
--- a/configure.in
+++ b/configure.in
@@ -86,8 +86,8 @@ AC_TRY_COMPILE([],
[AC_DEFINE(HAVE_PROTOTYPES) AC_MSG_RESULT(yes)],
AC_MSG_RESULT(no))
-dnl Check out the wait reality.
-AC_CHECK_HEADERS(sys/wait.h) AC_CHECK_FUNCS(waitpid wait3)
+dnl Check out the wait reality. We have to assume sys/wait.h is present.
+AC_CHECK_FUNCS(waitpid wait3)
AC_MSG_CHECKING(for union wait);
AC_TRY_LINK([#include <sys/types.h>
#include <sys/wait.h>],
diff --git a/daemon.c b/daemon.c
index ead23641..2995f1ef 100644
--- a/daemon.c
+++ b/daemon.c
@@ -7,18 +7,14 @@
#include <config.h>
#include <stdio.h>
+#include <signal.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <sys/file.h>
-#include <signal.h>
-#include <fcntl.h>
-
-#if defined(HAVE_SYS_WAIT_H)
-# include <sys/wait.h>
-#endif
+#include <sys/wait.h>
#if defined(HAVE_UNISTD_H)
-# include <unistd.h>
+#include <unistd.h>
#endif
#if defined(STDC_HEADERS)
@@ -26,7 +22,7 @@
#endif
#if defined(QNX)
-# include <unix.h>
+#include <unix.h>
#endif
/* BSD portability hack */
diff --git a/driver.c b/driver.c
index a8284a30..84e557f3 100644
--- a/driver.c
+++ b/driver.c
@@ -10,9 +10,9 @@
#include <stdio.h>
#include <setjmp.h>
#include <ctype.h>
+#include <string.h>
#if defined(STDC_HEADERS)
#include <stdlib.h>
-#include <string.h>
#endif
#if defined(HAVE_UNISTD_H)
#include <unistd.h>
diff --git a/fetchmail.c b/fetchmail.c
index 7d54fd7d..90a82c85 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -5,29 +5,18 @@
*/
#include <config.h>
-#include <stdio.h>
-#include <ctype.h>
-#include <time.h>
+#include <stdio.h>
#if defined(STDC_HEADERS)
#include <stdlib.h>
-#include <string.h>
#endif
-
#if defined(HAVE_UNISTD_H)
#include <unistd.h>
#endif
-
+#include <string.h>
#include <signal.h>
#include <pwd.h>
-#include <errno.h>
-
-#include <sys/types.h>
-#include <sys/file.h>
-#include <sys/wait.h>
-#include <sys/stat.h>
#include <sys/time.h>
-#include <fcntl.h>
#ifdef HAVE_GETHOSTBYNAME
#include <netdb.h>
diff --git a/options.c b/options.c
index f60747d9..31ca26eb 100644
--- a/options.c
+++ b/options.c
@@ -5,7 +5,7 @@
*/
#include <config.h>
-#include <stdio.h>
+
#include <pwd.h>
#include <string.h>
#if defined(STDC_HEADERS)
diff --git a/pop3.c b/pop3.c
index 0960085d..4df8473a 100644
--- a/pop3.c
+++ b/pop3.c
@@ -5,9 +5,9 @@
*/
#include <config.h>
+
#include <stdio.h>
#include <string.h>
-#include <ctype.h>
#if defined(HAVE_UNISTD_H)
#include <unistd.h>
#endif
diff --git a/smtp.c b/smtp.c
index 475b847a..f1908f81 100644
--- a/smtp.c
+++ b/smtp.c
@@ -9,9 +9,8 @@
* For license terms, see the file COPYING in this directory.
*/
-#include <stdio.h>
#include <config.h>
-#include <sys/types.h>
+#include <stdio.h>
#include <unistd.h>
#include <string.h>
#include "socket.h"
diff --git a/socket.c b/socket.c
index 7a98f83f..f0020adf 100644
--- a/socket.c
+++ b/socket.c
@@ -7,14 +7,11 @@
#include <config.h>
#include <stdio.h>
-#include <fcntl.h>
#include <sys/types.h>
#include <sys/socket.h>
-#include <netinet/in.h>
#include <arpa/inet.h>
#include <netdb.h>
#if defined(STDC_HEADERS)
-#include <string.h>
#include <stdlib.h>
#endif
#if defined(HAVE_UNISTD_H)
@@ -25,7 +22,6 @@
#else
#include <varargs.h>
#endif
-#include <errno.h>
#include "socket.h"
FILE *Socket(host, clientPort)
diff --git a/uid.c b/uid.c
index 25730390..f79c2ff0 100644
--- a/uid.c
+++ b/uid.c
@@ -7,10 +7,10 @@
#include <config.h>
#include <stdio.h>
+#include <string.h>
#if defined(STDC_HEADERS)
#include <stdlib.h>
-#include <string.h>
#endif
#if defined(HAVE_UNISTD_H)
diff --git a/xmalloc.c b/xmalloc.c
index 10b3d7e1..a58748a4 100644
--- a/xmalloc.c
+++ b/xmalloc.c
@@ -7,7 +7,6 @@
#include <config.h>
#include <stdio.h>
#include <string.h>
-#include <sys/types.h>
#if defined(STDC_HEADERS)
#include <stdlib.h>
#endif