aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2005-12-04 10:57:35 +0000
committerMatthias Andree <matthias.andree@gmx.de>2005-12-04 10:57:35 +0000
commit9b023cd530abe6ee2a9a7ba2a09f45d456aa2069 (patch)
tree57b2607be55217090080d3e2c5bceebc58bc1a8c
parent09e87694984e70cca180c27252d5d79fa4fa2d80 (diff)
downloadfetchmail-9b023cd530abe6ee2a9a7ba2a09f45d456aa2069.tar.gz
fetchmail-9b023cd530abe6ee2a9a7ba2a09f45d456aa2069.tar.bz2
fetchmail-9b023cd530abe6ee2a9a7ba2a09f45d456aa2069.zip
Support 'make lsm' to generate a .lsm file for ftp.ibiblio.com:/pub/Linux uploads.
This is meant to replace the insufficient rpm2lsm script. svn path=/branches/BRANCH_6-3/; revision=4502
-rw-r--r--Makefile.am4
-rw-r--r--configure.ac2
-rw-r--r--genlsm.sh.in32
-rwxr-xr-xspecgen.sh3
4 files changed, 40 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 764ca606..2d234b77 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -147,6 +147,10 @@ dist-hook:
cd $(distdir) && find $(distdirs) po -name .svn -type d -prune -exec rm -rf '{}' ';'
cd $(distdir) && find $(distdirs) po -name '*~' -exec rm -f '{}' ';'
+.PHONY: lsm
+lsm: genlsm.sh dist
+ $(SHELL) genlsm.sh >$(PACKAGE)-$(VERSION).lsm
+
# The following sets edit modes for GNU EMACS.
# Local Variables:
# compile-command:"configure"
diff --git a/configure.ac b/configure.ac
index e80759ca..f7441904 100644
--- a/configure.ac
+++ b/configure.ac
@@ -767,7 +767,7 @@ if test "$needtrio" = 1 ; then
fi
dnl ----------------------------------------------------------------'
-AC_CONFIG_FILES([Makefile m4/Makefile po/Makefile.in])
+AC_CONFIG_FILES([Makefile m4/Makefile po/Makefile.in genlsm.sh])
AC_OUTPUT
dnl Local Variables:
diff --git a/genlsm.sh.in b/genlsm.sh.in
new file mode 100644
index 00000000..4ce514c0
--- /dev/null
+++ b/genlsm.sh.in
@@ -0,0 +1,32 @@
+#! /bin/sh
+# @configure_input@
+
+# WARNING:
+# WARNING: If you change the description, also change specgen.sh!
+# WARNING:
+
+cat <<EOF
+Begin4
+Title: @PACKAGE@
+Version: @VERSION@
+Entered-date: `date -u +%Y-%m-%d`
+Description: Fetchmail is a free, full-featured, robust, and well-documented
+ remote mail retrieval and forwarding utility intended to be used
+ over on-demand TCP/IP links (such as SLIP or PPP connections).
+ It retrieves mail from remote mail servers and forwards it
+ to your local (client) machine's delivery system, so it can
+ then be be read by normal mail user agents such as mutt, elm,
+ pine, (x)emacs/gnus, or mailx. Comes with an interactive GUI
+ configurator (in Python/Tk) suitable for end-users.
+Keywords: mail, client, POP, POP2, POP3, APOP, RPOP, KPOP, IMAP, ETRN, ODMR, SMTP, ESMTP, GSSAPI, RPA, NTLM, CRAM-MD5, SASL
+Author: esr@thyrsus.com (Eric S. Raymond)
+ matthias.andree@gmx.de (Matthias Andree)
+ shetye@bombay.retortsoft.com (Sunil Shetye)
+ rfunk@funknet.net (Rob Funk)
+Maintained-by: fetchmail-devel@lists.berlios.de
+Primary-site: http://developer.berlios.de/projects/fetchmail
+ `ls -sk @PACKAGE@-@VERSION@.tar.bz2 | \
+ @AWK@ '{ printf "%dkB", $1 }'` @PACKAGE@-@VERSION@.tar.bz2
+Platforms: All
+Copying-policy: GPL
+End
diff --git a/specgen.sh b/specgen.sh
index cb042ab3..b1ddf588 100755
--- a/specgen.sh
+++ b/specgen.sh
@@ -1,5 +1,8 @@
#!/bin/sh
+# WARNING:
+# WARNING: If you change the description, also change genlsm.sh.in!
+# WARNING:
version="$1"
set -e