diff options
author | Eric S. Raymond <esr@thyrsus.com> | 2000-03-06 22:22:58 +0000 |
---|---|---|
committer | Eric S. Raymond <esr@thyrsus.com> | 2000-03-06 22:22:58 +0000 |
commit | 8512ca34be8fcaee3fb919262466949effc9fdf7 (patch) | |
tree | 29802537a5823d3d35a76336154768d3dd70a2a2 | |
parent | bcb9abf2ef08ea1edb88a9ece11600ba52d4f9cd (diff) | |
download | fetchmail-8512ca34be8fcaee3fb919262466949effc9fdf7.tar.gz fetchmail-8512ca34be8fcaee3fb919262466949effc9fdf7.tar.bz2 fetchmail-8512ca34be8fcaee3fb919262466949effc9fdf7.zip |
Ready for the experiment.
svn path=/trunk/; revision=2803
-rw-r--r-- | NEWS | 2 | ||||
-rw-r--r-- | configure.in | 3 | ||||
-rw-r--r-- | driver.c | 2 | ||||
-rw-r--r-- | uid.c | 3 |
4 files changed, 8 insertions, 2 deletions
@@ -7,6 +7,8 @@ * Fixed a bug in fetchmailconf's handling of envelope skip prefixes. * Don't nuke .fetchids when authorization failure keeps us from getting URLs. * Added FAQ item X6 on dropped and mangled attachments, thanks to Rob Funk. +* Teach configure.in to link the RSA reference library if available. +* Disable saving of Message-IDs into UIDL lists. There are 291 people on fetchmail-friends and 500 on fetchmail-announce. diff --git a/configure.in b/configure.in index 6abadb60..b753344a 100644 --- a/configure.in +++ b/configure.in @@ -154,6 +154,9 @@ AC_CHECK_FUNC(res_search, dnl Check for libcrypt AC_CHECK_LIB(crypt,crypt) +dnl Check for RSA refersence library in case we're using SSL +AC_CHECK_LIB(rsaref, _RSAPublicDecrypt) + dnl AC_FUNC_SETVBUF_REVERSED dnl Check for usable void pointer type @@ -725,6 +725,7 @@ static int readheaders(int sock, else if (!strncasecmp("Resent-Sender:", line, 14)) resent_sender_offs = (line - msgblk.headers); +#ifdef __UNUSED__ else if (!strncasecmp("Message-Id:", buf, 11)) { if (ctl->server.uidl) @@ -740,6 +741,7 @@ static int readheaders(int sock, } } } +#endif /* __UNUSED__ */ else if (!MULTIDROP(ctl)) continue; @@ -429,7 +429,7 @@ void uid_end_query(struct query *ctl) * This is necessary in order to keep UIDL information * from being heedlessly deleted later on. */ - if (ctl->have_uids) + if (ctl->newsaved) { /* old state of mailbox may now be irrelevant */ if (outlevel >= O_DEBUG) @@ -438,7 +438,6 @@ void uid_end_query(struct query *ctl) free_str_list(&scratchlist); ctl->oldsaved = ctl->newsaved; ctl->newsaved = (struct idlist *) NULL; - ctl->have_uids = FALSE; } else if (outlevel >= O_DEBUG) report(stdout, "not swapping UID lists, no UIDs seen this query\n"); |