aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1996-12-30 21:29:57 +0000
committerEric S. Raymond <esr@thyrsus.com>1996-12-30 21:29:57 +0000
commit7de2c0c1439beadc803fac522f7c1d91541fb247 (patch)
tree74590fe5c71658017f4bb13c51bf88492a50fd75
parenteb86f615066e71738f8f9ab924118e789380c873 (diff)
downloadfetchmail-7de2c0c1439beadc803fac522f7c1d91541fb247.tar.gz
fetchmail-7de2c0c1439beadc803fac522f7c1d91541fb247.tar.bz2
fetchmail-7de2c0c1439beadc803fac522f7c1d91541fb247.zip
Default to enable_stdio.
svn path=/trunk/; revision=709
-rw-r--r--configure.in33
1 files changed, 12 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index b8950a8e..7d1b1c5c 100644
--- a/configure.in
+++ b/configure.in
@@ -70,27 +70,6 @@ then
LIBS="$LIBS -lkrb -ldes"
fi
-dnl Configure command line options
-opt_enable_stdio=unset
-
-AC_ARG_ENABLE(stdio, --enable-stdio enable stdio for socket I/O, opt_enable_stdio=$enableval)
-
-if test $opt_enable_stdio = unset; then
- dnl Set USE_STDIO based on $host
- case $host in
- *-*-*freebsd*)
- AC_DEFINE(USE_STDIO)
- ;;
- case $host in
- *-*-*linux*)
- AC_DEFINE(USE_STDIO)
- ;;
- esac
-elif test $opt_enable_stdio = yes; then
- AC_DEFINE(USE_STDIO)
-fi
-
-
dnl All AC_CHECK_FUNCs must precede the following AC_SUBSTs
AC_SUBST(EXTRASRC)
@@ -140,6 +119,18 @@ AC_TRY_LINK([#include <signal.h>
[AC_DEFINE(SYS_SIGLIST_DECLARED) AC_MSG_RESULT(yes)],
AC_MSG_RESULT(no))
+dnl Configure command line options
+with_stdio="yes";
+AC_ARG_ENABLE(stdio,
+ [ --disable-stdio don't use standard I/O for socket buffering],
+ [with_stdio=$enableval],
+ [with_stdio=yes])
+if test "$with_stdio" = "yes"
+then
+ AC_DEFINE(USE_STDIO)
+ AC_MSG_RESULT("Dynamic buffering with stdio will be used for socket I/O")
+fi
+
AC_OUTPUT(Makefile, [
# Makefile uses this timestamp file to know when to remake Makefile,
# build.sh, and glob/Makefile.