aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1999-07-31 20:44:55 +0000
committerEric S. Raymond <esr@thyrsus.com>1999-07-31 20:44:55 +0000
commit79739caa154403260496d3b0c33f47ef0cf21447 (patch)
treed416492fcb57138c30db613e2171946d2c6fff1c
parent640a00628977de30f96e6c0fcc2289b28c3a8bac (diff)
downloadfetchmail-79739caa154403260496d3b0c33f47ef0cf21447.tar.gz
fetchmail-79739caa154403260496d3b0c33f47ef0cf21447.tar.bz2
fetchmail-79739caa154403260496d3b0c33f47ef0cf21447.zip
Before applying Brian Boutel's lexer fix.
svn path=/trunk/; revision=2518
-rw-r--r--NEWS10
-rw-r--r--configure.in2
-rw-r--r--fetchmail-FAQ.html11
-rw-r--r--fetchmail.c3
-rw-r--r--interface.c16
-rw-r--r--rcfile_l.l22
6 files changed, 51 insertions, 13 deletions
diff --git a/NEWS b/NEWS
index 8771b098..14938793 100644
--- a/NEWS
+++ b/NEWS
@@ -8,6 +8,16 @@
Release Notes:
+fetchmail-5.0.6 ():
+* Czech internationalization support (thanks to Jiri Pavlovsky).
+* Russion internationalization support (but I couldn't read the contributor
+ name in the headers!)
+* Update of the French internationalization support by Guy Brand.
+* Fix for the `nokeep' problem by Robert de Bath.
+* Interface option fix from Bill Currie.
+
+There are 267 people on fetchmail-friends and 420 on fetchmail-announce.
+
fetchmail-5.0.5 (Sat Jun 26 14:41:27 EDT 1999):
* Merged in official OpenBSD port patches.
* Added Spanish and German descriptions to spec (thanks to Horst von Brand).
diff --git a/configure.in b/configure.in
index 54722f86..c2255954 100644
--- a/configure.in
+++ b/configure.in
@@ -72,7 +72,7 @@ fi
# Arnaldo Carvalho de Melo <acme@conectiva.com.br>
# Sat Nov 7 15:39:03 EDT 1998
-ALL_LINGUAS="pt_BR es pl fr"
+ALL_LINGUAS="cs es fr pl pt_BR ru"
AM_GNU_GETTEXT
diff --git a/fetchmail-FAQ.html b/fetchmail-FAQ.html
index 772ddb6d..1b9693fe 100644
--- a/fetchmail-FAQ.html
+++ b/fetchmail-FAQ.html
@@ -10,7 +10,7 @@
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 1999/06/26 20:18:19 $
+<td width="30%" align=right>$Date: 1999/07/31 20:44:54 $
</table>
<HR>
<H1>Frequently Asked Questions About Fetchmail</H1>
@@ -820,6 +820,9 @@ you can add to your .bash_login and .bash_logout profiles that will
accomplish this. Thank James Laferriere &lt;babydr@nwrain.net&gt; for
it.<p>
+Some people start up and shut down fetchmail using the ppp-up and
+ppp-down scripts of pppd.<p>
+
<hr>
<h2><a name="C3">C3. How do I know what interface and address to use with --interface?</a></h2>
@@ -1682,9 +1685,9 @@ U.S. at this time, if the patches do leak out of the U.S. through no
fault of our own, and someone informs us of their location, we can
provide the URL pointing to archive sites outside of the U.S.<P>
-Newer versions of the SSL patches make appear in the `incoming' directory
+Newer versions of the SSL patches make appear in the `new' directory
and stay there a while until they can be processed and moved to the SSL
-directory. Check for patches in `incoming' if you do not find patches
+directory. Check for patches in `new' if you do not find patches
for the latest fetchmail release.<P>
<hr>
@@ -2425,7 +2428,7 @@ inactivity timeout.<p>
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 1999/06/26 20:18:19 $
+<td width="30%" align=right>$Date: 1999/07/31 20:44:54 $
</table>
<P><ADDRESS>Eric S. Raymond <A HREF="mailto:esr@thyrsus.com">&lt;esr@snark.thyrsus.com&gt;</A></ADDRESS>
diff --git a/fetchmail.c b/fetchmail.c
index 98428ff6..eaf1886a 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -45,7 +45,6 @@
#include "fetchmail.h"
#include "tunable.h"
#include "smtp.h"
-#include "getopt.h"
#include "netrc.h"
#include "i18n.h"
@@ -162,7 +161,7 @@ static void dropprivs(void)
}
#endif
-int main (int argc, char **argv)
+int main(int argc, char **argv)
{
int st, bkgd = FALSE;
int parsestatus, implicitmode = FALSE;
diff --git a/interface.c b/interface.c
index d93b096d..d1295f51 100644
--- a/interface.c
+++ b/interface.c
@@ -43,6 +43,7 @@
#include "config.h"
#include "fetchmail.h"
#include "i18n.h"
+#include "tunable.h"
typedef struct {
struct in_addr addr, dstaddr, netmask;
@@ -58,6 +59,13 @@ static char *netdevfmt;
#if defined(linux)
+/*
+ * Count of packets to see on an interface before monitor considers it up.
+ * Needed because when pppd shuts down the link, the packet counts go up
+ * by two (one rx and one tx?, maybe). A value of 2 seems to do the trick.
+ */
+#define MONITOR_SLOP 2
+
void interface_init(void)
/* figure out which /proc/dev/net format to use */
{
@@ -77,7 +85,7 @@ void interface_init(void)
if (major >= 2 && minor >= 2)
/* Linux 2.2 -- transmit packet count in 10th field */
- netdevfmt = "%d %d %*d %*d %*d %d %*d %*d %*d %*d %d %*d %d";
+ netdevfmt = "%d %d %*d %*d %*d %d %*d %*d %*d %d %*d %*d %d";
}
}
@@ -461,8 +469,8 @@ int interface_approve(struct hostdata *hp)
#endif
/* if monitoring, check link for activity if it is up */
if (get_ifinfo(hp->monitor, &ifinfo) &&
- hp->monitor_io == ifinfo.rx_packets +
- ifinfo.tx_packets) {
+ hp->monitor_io - (ifinfo.rx_packets +
+ ifinfo.tx_packets) >= -MONITOR_SLOP) {
(void) report(stdout,
_("skipping poll of %s, %s inactive\n"),
hp->pollname, hp->monitor);
@@ -470,7 +478,7 @@ int interface_approve(struct hostdata *hp)
}
#ifdef ACTIVITY_DEBUG
- error(0, 0, _("activity on %s was %d, is %d"),
+ report(stdout _("activity on %s was %d, is %d"),
hp->monitor, hp->monitor_io,
ifinfo.rx_packets + ifinfo.tx_packets);
#endif
diff --git a/rcfile_l.l b/rcfile_l.l
index f275e5a6..e5c4fba9 100644
--- a/rcfile_l.l
+++ b/rcfile_l.l
@@ -78,7 +78,25 @@ to { return TO; }
= { return MAP; }
"*" { return WILDCARD; }
-no/[a-z \t].* { return NO;}
+nobouncemail |
+nouidl |
+nocheckalias |
+nodns |
+noenvelope |
+nokeep |
+noflush |
+nofetchall |
+norewrite |
+noforcecr |
+nostripcr |
+nopass8(bits)? |
+nodropstatus |
+nomimedec(ode)? {
+ yyless(2);
+ return NO;
+ }
+
+no {return NO;}
keep { return KEEP; }
flush { return FLUSH; }
@@ -87,7 +105,7 @@ rewrite { return REWRITE; }
forcecr { return FORCECR; }
stripcr { return STRIPCR; }
pass8(bits)? { return PASS8BITS; }
-dropstatus? { return DROPSTATUS; }
+dropstatus { return DROPSTATUS; }
mimedec(ode)? { return MIMEDECODE; }
dns { return DNS; }
uidl { return UIDL; }