aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2000-03-11 00:59:57 +0000
committerEric S. Raymond <esr@thyrsus.com>2000-03-11 00:59:57 +0000
commit788d69daa64652cd382aa58a2c8ac3cbdea9b6b1 (patch)
tree612e8e46dca7341a8b08b0c2a718d7f0ff6a83a9
parenteb0e319b174a73671c41cffcac3a913bbe0ed5ba (diff)
downloadfetchmail-788d69daa64652cd382aa58a2c8ac3cbdea9b6b1.tar.gz
fetchmail-788d69daa64652cd382aa58a2c8ac3cbdea9b6b1.tar.bz2
fetchmail-788d69daa64652cd382aa58a2c8ac3cbdea9b6b1.zip
Better SOCKS5 support.
svn path=/trunk/; revision=2815
-rw-r--r--NEWS1
-rw-r--r--configure.in18
-rw-r--r--fetchmail-FAQ.html28
3 files changed, 24 insertions, 23 deletions
diff --git a/NEWS b/NEWS
index ade9eebb..ea902dae 100644
--- a/NEWS
+++ b/NEWS
@@ -3,6 +3,7 @@
(The `lines' figures total .c, .h, .l, and .y files under version control.)
* Fixed reporting of listener timeouts.
+* Configure now supports SOCKS5, thanks to Alan Schmitt.
fetchmail-5.3.2 (Mon Mar 6 21:41:23 EST 2000), 18695 lines:
diff --git a/configure.in b/configure.in
index b25e9d0c..6e06e7d5 100644
--- a/configure.in
+++ b/configure.in
@@ -500,6 +500,24 @@ then
LIBS="-lsocks $LIBS"
fi])
+### use option --with-socks5=DIR to point at SOCKS library
+AC_ARG_WITH(socks5,
+ [ --with-socks5[=DIR] add built-in SOCKS5 firewall access],
+[
+if test "$with_socks5" != no
+then
+ if test "$with_socks5" != yes
+ then
+ LDEFLAGS="$LDEFLAGS -L$with_socks5"
+ else
+ AC_CHECK_LIB(socks5, SOCKSconnect,,
+ AC_MSG_ERROR([could not find libsocks5 which is needed for built-in SOCKS5 support]))
+ fi
+ AC_DEFINE(HAVE_SOCKS)
+ CEFLAGS="$CEFLAGS -Dconnect=SOCKSconnect -Dgetsockname=SOCKSgetsockname -Dbind=SOCKSbind -Daccept=SOCKSaccept -Dlisten=SOCKSlisten -Dselect=SOCKSselect-Drecvfrom=SOCKSrecvfrom -Dsendto=SOCKSsendto -Drecv=SOCKSrecv -Dsend=SOCKSsend-Dread=SOCKSread -Dwrite=SOCKSwrite -Drresvport=SOCKSrresvport-Dshutdown=SOCKSshutdown -Dlisten=SOCKSlisten -Dclose=SOCKSclose -Ddup=SOCKSdup-Ddup2=SOCKSdup2 -Dfclose=SOCKSfclose -Dgethostbyname=SOCKSgethostbyname"
+ LIBS="-lsocks5 $LIBS"
+fi])
+
### use option --with-hesiod=DIR to point at a HESIOD directory
AC_ARG_WITH(hesiod,
[ --with-hesiod=DIR point fetchmail compilation at a HESIOD directory])
diff --git a/fetchmail-FAQ.html b/fetchmail-FAQ.html
index 62df7c01..0aa9c81f 100644
--- a/fetchmail-FAQ.html
+++ b/fetchmail-FAQ.html
@@ -10,7 +10,7 @@
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 2000/03/07 04:43:04 $
+<td width="30%" align=right>$Date: 2000/03/11 00:59:57 $
</table>
<HR>
<H1>Frequently Asked Questions About Fetchmail</H1>
@@ -1556,33 +1556,15 @@ RETR. <p>
<hr>
<h2><a name="K1">K1. How can I use fetchmail with SOCKS?</a></h2>
-Daniel Sobral &lt<a href="mailto:dcs@gns.com.br">dcs@gns.com.br</a>
-gave us the following recipe:<P>
-
-<OL>
-<LI> Install socks5. You don't need to have a socks server, you just
- want the "runsocks" program.
-<LI> Set the environment variable SOCKS_SERVER to the server you'll be
- using. Alternatively, you may set SOCKS4_SERVER and/or
- SOCKS5_SERVER. E.g.:
-<pre>
- export SOCKS5_SERVER=socks.my.domain.com
-</pre>
-<LI> Set SOCKS5_USER and SOCKS5_PASSWD if needed.
-<LI> Run fetchmail through runsocks. Just like this:
-<pre>
- runsocks fetchmail [parameters to fetchmail]
-</pre>
-</OL>
-
-It wasn't that hard, was it? :-)<P>
-
Giuseppe Guerini added a --with-socks option that supports linking
with socks library. If you specify the value of this option as
``yes'', the configure script will try to find the Rconnect library
and set the makefile up to link it. You can also specify a directory
containing the Rconnect library.<p>
+Alan Schmitt has added a similar --with-socks5 option that may work
+better if you have a recent version of the SOCKS library.
+
<hr>
<h2><a name="S7">S7. How can I use fetchmail with geocities POP3 servers?</a></h2>
@@ -2759,7 +2741,7 @@ terminate it.<p>
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 2000/03/07 04:43:04 $
+<td width="30%" align=right>$Date: 2000/03/11 00:59:57 $
</table>
<P><ADDRESS>Eric S. Raymond <A HREF="mailto:esr@thyrsus.com">&lt;esr@snark.thyrsus.com&gt;</A></ADDRESS>