aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Andree <matthias.andree@gmx.de>2005-08-02 01:45:12 +0000
committerMatthias Andree <matthias.andree@gmx.de>2005-08-02 01:45:12 +0000
commit7696fa59dd9e7c35388ce741006b14277095de30 (patch)
treea650bc67071f0db352158a41247ed35de34a13c4
parentcabbd0c9ca318c55e45af5a9aa0d01fce936ccd4 (diff)
downloadfetchmail-7696fa59dd9e7c35388ce741006b14277095de30.tar.gz
fetchmail-7696fa59dd9e7c35388ce741006b14277095de30.tar.bz2
fetchmail-7696fa59dd9e7c35388ce741006b14277095de30.zip
Generate fetchmailconf from Makefile to expand ${prefix} properly.
svn path=/trunk/; revision=4223
-rw-r--r--Makefile.am3
-rw-r--r--configure.ac3
-rw-r--r--fetchmailconf.in3
3 files changed, 4 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 7d969b3b..2a9998e6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -83,6 +83,9 @@ EXTRA_DIST= $(DISTDOCS) fetchmail.spec $(distdirs) ucs/README.svn \
trio/CHANGES trio/README strlcpy.3 \
m4-local/ac-archive-license.txt m4-local/ac_ma_search_package.m4
+fetchmailconf:
+ ( echo '#! /bin/sh' && echo 'exec @PYTHON@ @pythondir@/fetchmailconf.py "$$@"' ) >$@ || { rm -f $@ ; exit 1; }
+
FAQ: fetchmail-FAQ.html
AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/fetchmail-FAQ.html >$@ || { rm -f $@ ; exit 1 ; }
diff --git a/configure.ac b/configure.ac
index 34aeadbb..f15f2fff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -739,8 +739,7 @@ if test "$needtrio" = 1 ; then
fi
dnl ----------------------------------------------------------------'
-AC_CONFIG_FILES([Makefile m4/Makefile fetchmailconf
- po/Makefile.in])
+AC_CONFIG_FILES([Makefile m4/Makefile po/Makefile.in])
AC_OUTPUT
dnl Local Variables:
diff --git a/fetchmailconf.in b/fetchmailconf.in
deleted file mode 100644
index 79aa0922..00000000
--- a/fetchmailconf.in
+++ /dev/null
@@ -1,3 +0,0 @@
-#! /bin/sh
-
-exec @PYTHON@ fetchmailconf.py "$@"