aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1997-01-10 14:44:43 +0000
committerEric S. Raymond <esr@thyrsus.com>1997-01-10 14:44:43 +0000
commit623fd3dc50674b258991663149f813ec895adff7 (patch)
tree097705338bb9bf76474e968c8fba5878ba2c9049
parente522b2439da92cbe4dbbda1d5a3e48f27aeac6f4 (diff)
downloadfetchmail-623fd3dc50674b258991663149f813ec895adff7.tar.gz
fetchmail-623fd3dc50674b258991663149f813ec895adff7.tar.bz2
fetchmail-623fd3dc50674b258991663149f813ec895adff7.zip
Give up on trying to use stdio.
svn path=/trunk/; revision=734
-rw-r--r--acconfig.h3
-rw-r--r--configure.in12
-rw-r--r--socket.c59
3 files changed, 0 insertions, 74 deletions
diff --git a/acconfig.h b/acconfig.h
index 9f8434d0..54458058 100644
--- a/acconfig.h
+++ b/acconfig.h
@@ -32,9 +32,6 @@
/* Define if you have GNU's getopt family of functions. */
#undef HAVE_GETOPTLONG
-/* Define to enable use of stdio for socket I/O. */
-#undef USE_STDIO
-
/* Leave that blank line there!! Autoheader needs it.
If you're adding to this file, keep in mind:
diff --git a/configure.in b/configure.in
index 7d1b1c5c..ae45d083 100644
--- a/configure.in
+++ b/configure.in
@@ -119,18 +119,6 @@ AC_TRY_LINK([#include <signal.h>
[AC_DEFINE(SYS_SIGLIST_DECLARED) AC_MSG_RESULT(yes)],
AC_MSG_RESULT(no))
-dnl Configure command line options
-with_stdio="yes";
-AC_ARG_ENABLE(stdio,
- [ --disable-stdio don't use standard I/O for socket buffering],
- [with_stdio=$enableval],
- [with_stdio=yes])
-if test "$with_stdio" = "yes"
-then
- AC_DEFINE(USE_STDIO)
- AC_MSG_RESULT("Dynamic buffering with stdio will be used for socket I/O")
-fi
-
AC_OUTPUT(Makefile, [
# Makefile uses this timestamp file to know when to remake Makefile,
# build.sh, and glob/Makefile.
diff --git a/socket.c b/socket.c
index 1dd11a02..734321fc 100644
--- a/socket.c
+++ b/socket.c
@@ -34,33 +34,12 @@
#endif
#endif
-/*
- * There are, in effect, two different implementations here. One
- * uses read(2) and write(2) directly with no buffering, the other
- * uses stdio with line buffering (for better throughput). Both
- * are known to work under Linux. You get the former by configuring
- * with --disable-stdio, the latter by configuring with --enable-stdio
- * or by default.
- */
-
-#ifdef USE_STDIO
-/*
- * Size of buffer for internal buffering read function
- * don't increase beyond the maximum atomic read/write size for
- * your sockets, or you'll take a potentially huge performance hit
- */
-#define INTERNAL_BUFSIZE 2048
-#endif /* USE_STDIO */
-
FILE *SockOpen(char *host, int clientPort)
{
int sock;
unsigned long inaddr;
struct sockaddr_in ad;
struct hostent *hp;
-#ifdef USE_STDIO
- FILE *fp;
-#endif /* USE_STDIO */
memset(&ad, 0, sizeof(ad));
ad.sin_family = AF_INET;
@@ -86,15 +65,7 @@ FILE *SockOpen(char *host, int clientPort)
return (FILE *)NULL;
}
-#ifndef USE_STDIO
return fdopen(sock, "r+");
-#else
- fp = fdopen(sock, "r+");
-
- setvbuf(fp, NULL, _IOLBF, INTERNAL_BUFSIZE);
-
- return(fp);
-#endif /* USE_STDIO */
}
@@ -122,8 +93,6 @@ va_dcl {
}
-#ifndef USE_STDIO
-
int SockWrite(char *buf, int size, int len, FILE *sockfp)
{
int n, wrlen = 0;
@@ -167,34 +136,6 @@ char *SockGets(char *buf, int len, FILE *sockfp)
return buf;
}
-#else
-
-int SockWrite(char *buf, int size, int len, FILE *sockfp)
-{
- int n = fwrite(buf, size, len, sockfp);
-
- fseek(sockfp, 0L, SEEK_CUR); /* required by POSIX */
-
- return(n);
-}
-
-char *SockGets(char *buf, int len, FILE *sockfp)
-{
- char *in = fgets(buf, len, sockfp);
-
-#ifndef linux
- /*
- * Weirdly, this actually wedges under Linux (2.0.27 with libc 5.3.12-8).
- * It's apparently good under NEXTSTEP.
- */
- fseek(sockfp, 0L, SEEK_CUR); /* required by POSIX */
-#endif /* linux */
-
- return(in);
-}
-
-#endif
-
#ifdef MAIN
/*
* Use the chargen service to test input beuffering directly.