aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-03-07 16:05:24 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-03-07 16:05:24 +0000
commit611d2ed7bca45b9f572e14521b744df1b3f1e5e1 (patch)
tree400524c5fa075bc589c83db396ac77145d8f6d1c
parentceca8872529ac73d4fc115c6bb3d8bb1ef7cffe3 (diff)
downloadfetchmail-611d2ed7bca45b9f572e14521b744df1b3f1e5e1.tar.gz
fetchmail-611d2ed7bca45b9f572e14521b744df1b3f1e5e1.tar.bz2
fetchmail-611d2ed7bca45b9f572e14521b744df1b3f1e5e1.zip
Use sendmail if we find it.
svn path=/trunk/; revision=3213
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d8544126..060ab50c 100644
--- a/configure.in
+++ b/configure.in
@@ -207,12 +207,21 @@ AC_MSG_RESULT(root-mode pid file will go in $dir)
AC_DEFINE_UNQUOTED(PID_DIR, "$dir")
# We may have a fallback MDA available in case the socket open to the
-# local SMTP listener fails...
+# local SMTP listener fails. Best to use procmail for this, as we know
+# it won't try delivering through local SMTP and cause a mail loop.
+# Sendmail without the -t option to use the message headers will work too,
+# not just for sendmail itself but for workalikes like exim.
AC_PATH_PROG(procmail, procmail, "", $PATH:/usr/sbin)
if test "$procmail"
then
echo "Found procmail, will use it as a fallback MDA."
AC_DEFINE(FALLBACK_MDA, "$procmail -d %T")
+ AC_PATH_PROG(sendmail, sendmail, "", $PATH:/usr/sbin)
+ if test "$sendmail"
+ then
+ echo "Found sendmail, will use it as a fallback MDA."
+ AC_DEFINE(FALLBACK_MDA, "$sendmail %T")
+ fi
fi
AC_CHECK_SIZEOF(short)