aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1996-10-11 17:07:06 +0000
committerEric S. Raymond <esr@thyrsus.com>1996-10-11 17:07:06 +0000
commit5a80670189c8290e6bd71cbadd8c8eec24fb06ca (patch)
tree8e916cb3c8bb904ee9f5dc1b53c2c3bb3b0284c5
parentfbcc5b4a0e29ac80375898e3c5ab6dd9a1c3080a (diff)
downloadfetchmail-5a80670189c8290e6bd71cbadd8c8eec24fb06ca.tar.gz
fetchmail-5a80670189c8290e6bd71cbadd8c8eec24fb06ca.tar.bz2
fetchmail-5a80670189c8290e6bd71cbadd8c8eec24fb06ca.zip
Better makedepend usage.
svn path=/trunk/; revision=315
-rw-r--r--Makefile.in10
1 files changed, 4 insertions, 6 deletions
diff --git a/Makefile.in b/Makefile.in
index 4b4a8ab7..b3e85b31 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -88,11 +88,6 @@ srcs = $(srcdir)/socket.c $(srcdir)/getpass.c $(srcdir)/pop2.c \
all: fetchmail fetchmail.spec
-depend:
- test -f config.h || touch config.h
- test -f rcfile_y.h || touch rcfile_y.h
- makedepend -fMakefile *.c
-
# Some makes apparently use .PHONY as the default goal if it is before `all'.
.PHONY: all check
@@ -182,6 +177,8 @@ mostlyclean: clean
Makefile: config.status $(srcdir)/Makefile.in
$(SHELL) config.status
+ @echo "You can ignore any makedepend error messages"
+ -makedepend -fMakefile *.c
config.h: stamp-config
@@ -228,4 +225,5 @@ fetchmail-$(VERS).tar.gz: fetchmail-$(VERS).tar
# ``#include "config.h"''. So we add the explicit dependency to make sure.
$(objs): config.h
-# Automatically generated dependencies will be put at the end of the file.
+# Automatically generated dependencies will be put at the end of the makefile.
+# DO NOT DELETE THIS LINE -- make depend depends on it.