aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1997-04-04 22:37:12 +0000
committerEric S. Raymond <esr@thyrsus.com>1997-04-04 22:37:12 +0000
commit53b50716e3d468da291c646829671f794bf034f0 (patch)
tree48688c04510aff124ae4be613b6fc67783fcbf86
parent1ca56b9f77ca7f06d5d4ccf37b606c20354c94ff (diff)
downloadfetchmail-53b50716e3d468da291c646829671f794bf034f0.tar.gz
fetchmail-53b50716e3d468da291c646829671f794bf034f0.tar.bz2
fetchmail-53b50716e3d468da291c646829671f794bf034f0.zip
Ready to ship 3.9.1.
svn path=/trunk/; revision=951
-rw-r--r--Makefile.in11
-rw-r--r--NEWS19
-rwxr-xr-xspecgen.sh6
3 files changed, 23 insertions, 13 deletions
diff --git a/Makefile.in b/Makefile.in
index 42077848..5a9094ee 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,7 @@
# So just uncomment all the lines marked QNX.
VERS=3.9
-PL=0
+PL=1
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
@@ -197,7 +197,7 @@ extra = $(srcdir)/alloca.c $(srcdir)/getopt.[ch] $(srcdir)/getopt1.c \
$(srcdir)/strcasecmp.c
docs = $(srcdir)/COPYING $(srcdir)/README $(srcdir)/INSTALL $(srcdir)/NEWS \
$(srcdir)/NOTES $(srcdir)/fetchmail.lsm $(srcdir)/sample.rcfile \
- $(srcdir)/*.man $(srcdir)/FAQ $(srcdir)/fetchmail-FAQ.html
+ $(srcdir)/*.man $(srcdir)/FAQ $(srcdir)/fetchmail.FAQ.html
config = $(srcdir)/Makefile.in $(srcdir)/configure.in $(srcdir)/configure \
$(srcdir)/config.guess $(srcdir)/config.h.in $(srcdir)/config.sub \
$(srcdir)/acconfig.h
@@ -208,8 +208,8 @@ all = $(docs) $(config) $(srcs) $(parser) $(headers) $(extra) $(scripts) \
MANIFEST: $(srcdir)
@echo $(all) | tr "[ \t]" '\n' | sort | sed "s/\\./fetchmail-$(VERS)/" >MANIFEST
-FAQ: fetchmail-FAQ.html
- lynx -dump -nolist fetchmail-FAQ.html >FAQ
+FAQ: fetchmail.FAQ.html
+ lynx -dump -nolist fetchmail.FAQ.html >FAQ
dist: fetchmail-$(VERS).tar.gz
ls -l fetchmail-$(VERS).tar.gz
@@ -220,6 +220,7 @@ fetchmail-$(VERS).tar: $(all)
fetchmail-$(VERS).tar.gz: fetchmail-$(VERS).tar
gzip -f fetchmail-$(VERS).tar
+# You need to be root to make this work
RPMROOT=/usr/src/redhat
RPM = rpm
RPMFLAGS = -ba
@@ -227,6 +228,8 @@ rpm: fetchmail-$(VERS).tar.gz
cp fetchmail-$(VERS).tar.gz $(RPMROOT)/SOURCES;
$(srcdir)/specgen.sh $(VERS) $(PL) >$(RPMROOT)/SPECS/fetchmail.spec
cd $(RPMROOT)/SPECS; $(RPM) $(RPMFLAGS) fetchmail.spec
+ cp $(RPMROOT)/RPMS/i386/fetchmail-$(VERS)*.rpm $(srcdir)
+ cp $(RPMROOT)/SRPMS/fetchmail-$(VERS)*.src.rpm $(srcdir)
# The automatically generated dependencies below may omit config.h
# because it is included with ``#include <config.h>'' rather than
diff --git a/NEWS b/NEWS
index d5e74d04..5bf374fb 100644
--- a/NEWS
+++ b/NEWS
@@ -1,15 +1,22 @@
Heads-up!
-The .poprc compatibility hack that allows your first user declaration
-per server to omit the "username" keyword. has been causing some
-confusion (see question F3 in the FAQ for details). Use of the
-feature now generates a warning to standard error. In a future
-release, probably 4.0, this hack will be removed and the leading
-`username' token required for every user entry.
+The .poprc compatibility hack that allows the first user declaration of
+more than one in a server entry to omit the "username" keyword has been
+causing some confusion (see question F3 in the FAQ for details). This now
+generates a warning to standard error. In a future release, probably 4.0,
+this hack will be removed and the leading `username' token required for
+every user entry in a multi-user poll declaration.
Release Notes:
------------------------------------------------------------------------------
+
+pl 3.9.1 (Fri Apr 4 17:24:14 EST 1997):
+* Hypertext FAQ added to distribution manifest.
+* RPM builder production fixed.
+* Minor additions to man page.
+
+------------------------------------------------------------------------------
fetchmail-3.9 (Wed Apr 2 13:36:22 EST 1997)
features --
diff --git a/specgen.sh b/specgen.sh
index bab75f56..f20fc5a5 100755
--- a/specgen.sh
+++ b/specgen.sh
@@ -1,10 +1,10 @@
cat <<EOF
-Description: Remote mail fetcher for POP2, POP3, APOP, IMAP
+Description: Remote mail fetch daemon for POP2, POP3, APOP, IMAP
Name: fetchmail
Version: ${1}
Release: ${2}
Source: locke.ccil.org:/pub/esr/fetchmail/fetchmail-${1}.tar.gz
-Copyright: distributable
+Copyright: freely redistributable
Group: Mail
%prep
@@ -18,7 +18,7 @@ make
make install
%files
-%doc README NEWS NOTES FAQ COPYING INSTALL sample.rcfile
+%doc README NEWS NOTES fetchmail.FAQ.html FAQ COPYING INSTALL sample.rcfile
%ifarch i386
%endif