aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-03-04 23:41:16 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-03-04 23:41:16 +0000
commit3d078768f97dc86fedd7779c94132c176373e0af (patch)
tree1e19575d3b5168c8b38a18e9cabaef4d1ee03aaa
parent9b5547ffab5538f739aae762aa2dcc1fa6b4e858 (diff)
downloadfetchmail-3d078768f97dc86fedd7779c94132c176373e0af.tar.gz
fetchmail-3d078768f97dc86fedd7779c94132c176373e0af.tar.bz2
fetchmail-3d078768f97dc86fedd7779c94132c176373e0af.zip
Incorporated Red Hat's Kerveros patch.
svn path=/trunk/; revision=3197
-rw-r--r--Makefile.in2
-rw-r--r--NEWS3
-rw-r--r--configure.in25
3 files changed, 26 insertions, 4 deletions
diff --git a/Makefile.in b/Makefile.in
index 79872125..29935bc9 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -230,7 +230,7 @@ config.status: configure
./config.status --recheck
$(srcdir)/aclocal.m4: configure.in
- cd $(srcdir) && aclocal -I m4
+ cd $(srcdir) && aclocal
# This tells versions [3.59,3.63) of GNU make not to export all variables.
.NOEXPORT:
diff --git a/NEWS b/NEWS
index fe032918..e6641133 100644
--- a/NEWS
+++ b/NEWS
@@ -6,6 +6,9 @@
Now builds with NLS by default, unavoidable side effect of fix.
* Various cleanups and minor bugfixes in OTP support.
* Corrected header error in SSL support.
+* Updated Spanish translation by Javier Kohen.
+* Incorporated Red Hat's 5.5.0 Kerberos V patch.
+* Incorporated Henrique Holschuh's fetchmailconf warning on local names with @.
fetchmail-5.7.1 (Sun Mar 4 00:30:04 EST 2001), 20167 lines:
diff --git a/configure.in b/configure.in
index d618c4ae..6c7a2e71 100644
--- a/configure.in
+++ b/configure.in
@@ -341,7 +341,8 @@ test "$with_netsec" = "yes" && AC_DEFINE(NET_SECURITY)
### use option --with-kerberos5=DIR to point at a Kerberos 5 directory
AC_ARG_WITH(kerberos5,
- [ --with-kerberos5=DIR point fetchmail compilation at a Kerberos 5 directory])
+ [ --with-kerberos5=DIR point fetchmail compilation at a Kerberos 5 directory],
+ with_kerberos5=$withval)
# The "then" arm (nonempty $with_kerberos5) is kind of a crock. It works for
# configuring the BSD/OS Kerberos V support, though.
@@ -352,12 +353,21 @@ then
AC_DEFINE(KERBEROS_V5)
CEFLAGS="$CEFLAGS -I$with_kerberos5/include"
LDEFLAGS="$LDEFLAGS -L$with_kerberos5/lib"
+ AC_CHECK_LIB(crypto,
+ krb5_des_string_to_key,
+ libk5crypto=-lcrypto,
+ AC_CHECK_LIB(k5crypto,
+ krb5_des_string_to_key,
+ libk5crypto=-lk5crypto,
+ AC_ERROR(Kerberos 5 libraries not found),
+ ${LDEFLAGS} -lcom_err),
+ ${LDEFLAGS} -lcom_err)
if test -f "$with_kerberos5/include/roken.h"
then
AC_DEFINE(HEIMDAL)
LIBS="$LIBS -lkrb5 -lasn1 -ldes -lroken -lcom_err"
else
- LIBS="$LIBS -lkrb5 -lcrypto -lcom_err"
+ LIBS="$LIBS -lkrb5 ${libk5crypto} -lcom_err"
fi
elif test "$with_kerberos" != "no" -a "$with_kerberos5" != "no" ; then
for dir in /usr/kerberos /usr/local/krb5 /usr/athena
@@ -372,7 +382,16 @@ elif test "$with_kerberos" != "no" -a "$with_kerberos5" != "no" ; then
AC_DEFINE(HEIMDAL)
LIBS="$LIBS -lkrb5 -lasn1 -ldes -lcom_err"
else
- LIBS="$LIBS -lkrb5 -lcrypto -lcom_err"
+ AC_CHECK_LIB(crypto,
+ krb5_des_string_to_key,
+ libk5crypto=-lcrypto,
+ AC_CHECK_LIB(k5crypto,
+ krb5_des_string_to_key,
+ libk5crypto=-lk5crypto,
+ AC_ERROR(Kerberos 5 libraries not found),
+ ${LDEFLAGS} -lcom_err),
+ ${LDEFLAGS} -lcom_err)
+ LIBS="$LIBS -lkrb5 ${libk5crypto} -lcom_err"
fi
with_kerberos5=$dir
break