aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1997-07-01 13:30:55 +0000
committerEric S. Raymond <esr@thyrsus.com>1997-07-01 13:30:55 +0000
commit3a854764c9fe5ce324c1f14fd70fc84bd8cfad27 (patch)
treec38e7be8d06fe2ff335c39ee10e5f30917487850
parent6cb14cf01403e881877a20f70a176fd1a48afe0e (diff)
downloadfetchmail-3a854764c9fe5ce324c1f14fd70fc84bd8cfad27.tar.gz
fetchmail-3a854764c9fe5ce324c1f14fd70fc84bd8cfad27.tar.bz2
fetchmail-3a854764c9fe5ce324c1f14fd70fc84bd8cfad27.zip
Fix Roidl's problem.
svn path=/trunk/; revision=1128
-rw-r--r--configure.in2
-rw-r--r--daemon.c7
2 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index f531ca25..9ab2db52 100644
--- a/configure.in
+++ b/configure.in
@@ -23,7 +23,7 @@ AC_HEADER_STDC
AC_TYPE_SIZE_T
AC_TYPE_PID_T
AC_TYPE_SIGNAL
-AC_CHECK_HEADERS(unistd.h termios.h termio.h sgtty.h stdarg.h alloca.h sys/itimer.h)
+AC_CHECK_HEADERS(unistd.h termios.h termio.h sgtty.h stdarg.h alloca.h sys/itimer.h fcntl.h sys/fcntl.h)
AC_C_CONST dnl getopt needs this.
diff --git a/daemon.c b/daemon.c
index 4d159257..2bf69682 100644
--- a/daemon.c
+++ b/daemon.c
@@ -11,7 +11,12 @@
#include <signal.h>
#include <sys/types.h>
#include <sys/wait.h>
-#include <sys/fcntl.h> /* Solaris 2.5 requires this */
+#ifdef HAVE_FCNTL_H
+#include <fcntl.h>
+#endif /* HAVE_FCNTL_H */
+#ifdef HAVE_SYS_FCNTL_H
+#include <sys/fcntl.h>
+#endif /* HAVE_SYS_FCNTL_H */
#include <sys/stat.h> /* get umask(2) prototyped */
#if defined(HAVE_UNISTD_H)