diff options
author | Eric S. Raymond <esr@thyrsus.com> | 1998-05-22 17:25:00 +0000 |
---|---|---|
committer | Eric S. Raymond <esr@thyrsus.com> | 1998-05-22 17:25:00 +0000 |
commit | 36bc0ab5bf2bfd56fb7e25dfbae194703b60304e (patch) | |
tree | f4a6706527b9b0d85f7600c9801f6dc865b57a90 | |
parent | 457c1fe4e4f1f233a590cf38b779ca0fdcc6b18d (diff) | |
download | fetchmail-36bc0ab5bf2bfd56fb7e25dfbae194703b60304e.tar.gz fetchmail-36bc0ab5bf2bfd56fb7e25dfbae194703b60304e.tar.bz2 fetchmail-36bc0ab5bf2bfd56fb7e25dfbae194703b60304e.zip |
Various bug fixes.
svn path=/trunk/; revision=1792
-rw-r--r-- | NEWS | 8 | ||||
-rw-r--r-- | configure.in | 11 | ||||
-rw-r--r-- | fetchmail.c | 2 | ||||
-rw-r--r-- | fetchmail.man | 4 | ||||
-rw-r--r-- | rcfile_y.y | 2 |
5 files changed, 21 insertions, 6 deletions
@@ -7,8 +7,14 @@ Release Notes: ------------------------------------------------------------------------------ -fetchmail-4.4.6 () +fetchmail-4.4.7 () +* FEATURE FREEZE IS NOW IN EFFECT! No new features until after 4.5.0. * Better workaround for TOP bounds-checking in qpopper 2.3+. +* Gunther Leber's fix to processing of command-line options. +* George Colouris's second try at NetBSD autoconfiguration. +* Bruce Mah's fix for core dump in command-line host specification. +* Mimedecode default turned off pending a fix for the PGP-signature- + munging bug. There are 270 people on fetchmail-friends and 212 on fetchmail-announce. diff --git a/configure.in b/configure.in index 5bdbe34d..280728c2 100644 --- a/configure.in +++ b/configure.in @@ -250,9 +250,16 @@ fi AC_ARG_WITH(kerberos, [ --with-kerberos=DIR point fetchmail compilation at a Kerberos directory]) -# The "then" arm (nonempty $with_kerberos) is kind of a crock. It works for +# The "elif" arm (nonempty $with_kerberos) is kind of a crock. It works for # configuring the BSD/OS Kerberos IV support, though. -if test -n "$with_kerberos" + +# Check for a NetBSD special case +if test "$with_kerberos" = "yes" -a `uname` = "NetBSD" +then + echo "Configuring kerberosIV for NetBSD" + CEFLAGS="$CEFLAGS -DKERBEROS_V4 -I/usr/include/kerberosIV" + LIBS="$LIBS -lkrb -ldes" +elif test -n "$with_kerberos" then CEFLAGS="$CEFLAGS -DKERBEROS_V4 -I$with_kerberos/include" LDEFLAGS="$LDEFLAGS -L$with_kerberos/lib" diff --git a/fetchmail.c b/fetchmail.c index 09dbb271..63d4cdc8 100644 --- a/fetchmail.c +++ b/fetchmail.c @@ -758,7 +758,7 @@ static int load_params(int argc, char **argv, int optind) DEFAULT(ctl->forcecr, FALSE); DEFAULT(ctl->pass8bits, FALSE); DEFAULT(ctl->dropstatus, FALSE); - DEFAULT(ctl->mimedecode, TRUE); + DEFAULT(ctl->mimedecode, FALSE); DEFAULT(ctl->server.dns, TRUE); DEFAULT(ctl->server.uidl, FALSE); #undef DEFAULT diff --git a/fetchmail.man b/fetchmail.man index 355221e2..b607f016 100644 --- a/fetchmail.man +++ b/fetchmail.man @@ -917,7 +917,7 @@ dropstatus \& T{ Strip Status and X-Mozilla-Status lines out of incoming mail T} mimedecode \& T{ -Convert quoted-printable to 8-bit in MIME messages (default) +Convert quoted-printable to 8-bit in MIME messages T} no keep -K T{ Delete seen messages from server (default) @@ -944,7 +944,7 @@ no dropstatus \& T{ Don't drop Status headers (default) T} no mimedecode \& T{ -Don't convert quoted-printable to 8-bit in MIME messages +Don't convert quoted-printable to 8-bit in MIME messages (default) T} limit -l T{ Set message size limit @@ -436,6 +436,8 @@ struct query *init; /* pointer to block containing initial values */ /* initialize it */ if (init) memcpy(node, init, sizeof(struct query)); + else + memset(node, '\0', sizeof(struct query)); /* append to end of list */ if (hosttail != (struct query *) 0) |