aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>1997-09-25 06:42:29 +0000
committerEric S. Raymond <esr@thyrsus.com>1997-09-25 06:42:29 +0000
commit3140c08b2e098606763eece6bf53a2c48e069e05 (patch)
tree161e97aa03610ff1bd08ecf412b277bb034608dd
parent10b84a40c3316accfa2446a386452536b37d55e9 (diff)
downloadfetchmail-3140c08b2e098606763eece6bf53a2c48e069e05.tar.gz
fetchmail-3140c08b2e098606763eece6bf53a2c48e069e05.tar.bz2
fetchmail-3140c08b2e098606763eece6bf53a2c48e069e05.zip
First pass at OPIE 2.32 support.
svn path=/trunk/; revision=1407
-rw-r--r--INSTALL9
-rw-r--r--Makefile.in2
-rw-r--r--NEWS5
-rw-r--r--configure.in21
-rw-r--r--fetchmail-features.html6
-rw-r--r--pop3.c2
6 files changed, 29 insertions, 16 deletions
diff --git a/INSTALL b/INSTALL
index 2fb39b3b..f5615267 100644
--- a/INSTALL
+++ b/INSTALL
@@ -13,14 +13,15 @@ running fetchmail.
1. USEFUL THINGS TO INSTALL FIRST
If you want support for RFC1938-compliant one-time passwords, you'll
-need to install Craig Metz's OPIE libraries first. Then configure
-with --enable-OPIE, and fetchmail build process will detect them and
-compile appropriately.
+need to install Craig Metz's OPIE libraries first and *make sure
+they're on the normal library path* where configure will find them. Then
+configure with --enable-OPIE, and fetchmail build process will detect
+them and compile appropriately.
Note: there is no point in doing this unless your server is
OTP-enabled. To test this, telnet to the server port and give it
a valid USER id. If the OK response includes the string "otp-",
-you should install OPIE.
+you should install OPIE. You need version 2.32 or better.
The OPIE library sources are available at ftp://ftp.inner.net/pub/opie.
diff --git a/Makefile.in b/Makefile.in
index 63dfb2df..77431e65 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -206,7 +206,7 @@ config = $(srcdir)/Makefile.in $(srcdir)/configure.in $(srcdir)/configure \
scripts = $(srcdir)/install.sh $(srcdir)/mkinstalldirs \
$(srcdir)/specgen.sh $(srcdir)/lsmgen.sh
all = $(docs) $(config) $(srcs) $(parser) $(headers) $(extra) $(scripts) \
- $(srcdir)/contrib/*[A-Za-uw-z] $(srcdir)/MANIFEST $(srcdir)/LIBOPIE.PATCH
+ $(srcdir)/contrib/*[A-Za-uw-z] $(srcdir)/MANIFEST
MANIFEST: $(srcdir) Makefile.in
@echo $(all) | tr "[ \t]" '\n' | sed -e '/^\.\//s///' | sort >MANIFEST
diff --git a/NEWS b/NEWS
index 2a1d5edf..bfd5ed68 100644
--- a/NEWS
+++ b/NEWS
@@ -12,6 +12,11 @@
Release Notes:
------------------------------------------------------------------------------
+fetchmail-4.2.7 ()
+* Full OTP support with Craig Metz's libopie 2.32 or higher.
+
+There are 283 people on the fetchmail-friends list.
+
fetchmail-4.2.6 (Wed Sep 24 17:37:13 EDT 1997)
* Prevent bad matches on Received line due to hostnames ending "for" and "by".
* Improved bug-tracking header, now also emitted when using an MDA.
diff --git a/configure.in b/configure.in
index 9bdafd25..65ea20b4 100644
--- a/configure.in
+++ b/configure.in
@@ -47,8 +47,6 @@ AC_CHECK_FUNC(inet_addr,
AC_MSG_RESULT(using libc's inet_addr),
AC_CHECK_LIB(nsl,inet_addr))
-AC_CHECK_LIB(opie,opiegenerator)
-
dnl Port hack for Interactive UNIX System V/386 Release 3.2
AC_CHECK_LIB(cposix, strchr,
[EXTRADEFS="$EXTRADEFS -D_SYSV3"
@@ -156,12 +154,19 @@ AC_ARG_ENABLE(POP2,
[with_POP2=no])
test "$with_POP2" = "yes" && AC_DEFINE(POP2_ENABLE)
-### use option --enable-OPIE to compile in the OPIE support
-AC_ARG_ENABLE(OPIE,
- [ --enable-OPIE compile in OPIE protocol support (obsolete)],
- [with_OPIE=$enableval],
- [with_OPIE=no])
-test "$with_OPIE" = "yes" && AC_DEFINE(OPIE_ENABLE)
+### use option --enable-opie to compile in the OPIE support
+AC_ARG_ENABLE(opie,
+ [ --enable-opie support OTP through the OPIE library],
+ [with_opie=$enableval],
+ [with_opie=no])
+if test "$with_opie" = "yes";
+then
+ AC_CHECK_HEADER(opie,,
+ [echo 'configure: cannot find <opie.h>, which is required for OPIE support.'; exit 1])
+ AC_CHECK_LIB(opie,opiegenerator,,
+ [echo 'configure: cannot find libopie, which is required for OPIE support.'; exit 1])
+ AC_DEFINE(OPIE,1)
+fi
### use option --with-kerberos=DIR to point at a Kerberos directory
AC_ARG_WITH(kerberos,
diff --git a/fetchmail-features.html b/fetchmail-features.html
index fadd3381..9978889f 100644
--- a/fetchmail-features.html
+++ b/fetchmail-features.html
@@ -10,7 +10,7 @@
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 1997/09/24 17:51:46 $
+<td width="30%" align=right>$Date: 1997/09/25 06:42:28 $
</table>
<HR>
@@ -25,7 +25,7 @@ are listed first. <P>
and Post Office/NT.
<LI> Support for responding with a one-time password when a POP3 server
- issues an RFC1938-conforming OTP challenge. (Still experimental)
+ issues an RFC1938-conforming OTP challenge.
</UL>
<H2>Since 3.0:</H2>
@@ -129,7 +129,7 @@ get-mail, gwpop, pimp-1.0, pop-perl5-1.2, popc, popmail-1.6 and upop.<P>
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 1997/09/24 17:51:46 $
+<td width="30%" align=right>$Date: 1997/09/25 06:42:28 $
</table>
<P><ADDRESS>Eric S. Raymond <A HREF="mailto:esr@thyrsus.com">&lt;esr@snark.thyrsus.com&gt;</A></ADDRESS>
diff --git a/pop3.c b/pop3.c
index b557a0e9..c6de4333 100644
--- a/pop3.c
+++ b/pop3.c
@@ -150,6 +150,8 @@ int pop3_getauth(int sock, struct query *ctl, char *greeting)
if (ok != 2)
PROTOCOL_ERROR
}
+
+ /* otherwise generate a challenge from the secret we have */
else if (opiegenerator(challenge, ctl->password, response))
PROTOCOL_ERROR