aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-07-31 05:54:41 +0000
committerEric S. Raymond <esr@thyrsus.com>2001-07-31 05:54:41 +0000
commit2dd4055cf26d85600a22205ae6e9ed668d614f26 (patch)
treebe3d15a8fbe7aa76b2310149633b677f08c5b53d
parent2cb642fc7d5ad94fe4c48a5d0ec198ab0ac423e9 (diff)
downloadfetchmail-2dd4055cf26d85600a22205ae6e9ed668d614f26.tar.gz
fetchmail-2dd4055cf26d85600a22205ae6e9ed668d614f26.tar.bz2
fetchmail-2dd4055cf26d85600a22205ae6e9ed668d614f26.zip
Must solve that damn linking problem next.
svn path=/trunk/; revision=3426
-rw-r--r--Makefile.in2
-rw-r--r--configure.in8
-rw-r--r--design-notes.html20
-rw-r--r--fetchmail.man11
-rw-r--r--imap.c12
-rwxr-xr-xindexgen.sh7
-rw-r--r--rcfile_y.y3
-rw-r--r--sink.c2
8 files changed, 43 insertions, 22 deletions
diff --git a/Makefile.in b/Makefile.in
index 7b1ccb86..b5c2c745 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,7 @@
# So just uncomment all the lines marked QNX.
PACKAGE = fetchmail
-VERSION = 5.8.14
+VERSION = 5.8.15
# Ultrix 2.2 make doesn't expand the value of VPATH.
srcdir = @srcdir@
diff --git a/configure.in b/configure.in
index 9411026e..43f2fbfb 100644
--- a/configure.in
+++ b/configure.in
@@ -240,23 +240,23 @@ case "$enable_fallback" in
AC_ERROR([Sendmail selected as fallback, but not found])
#not reached
fi
- AC_DEFINE(FALLBACK_MDA, "$sendmail %T")
+ AC_DEFINE_UNQUOTED(FALLBACK_MDA, "$sendmail %T")
echo "Will use $sendmail as fallback MDA."
;;
procmail) if test -z "$procmail" ; then
AC_ERROR([procmail selected as fallback, but not found])
#not reached
fi
- AC_DEFINE(FALLBACK_MDA, "$procmail -d %T")
+ AC_DEFINE_UNQUOTED(FALLBACK_MDA, "$procmail -d %T")
echo "Will use $procmail as fallback MDA."
;;
no|unset) echo "Will not use a fallback MDA"
;;
auto|yes|set) if test -n "$procmail" ; then
- AC_DEFINE(FALLBACK_MDA, "$procmail -d %T")
+ AC_DEFINE_UNQUOTED(FALLBACK_MDA,"$procmail -d %T")
echo "Will use $procmail as fallback MDA."
elif test -n "$sendmail" ; then
- AC_DEFINE(FALLBACK_MDA, "$sendmail %T")
+ AC_DEFINE_UNQUOTED(FALLBACK_MDA,"$sendmail %T")
echo "Will use $sendmail as fallback MDA."
else echo "No fallback MDA available."
fi
diff --git a/design-notes.html b/design-notes.html
index 27b4ccf3..2054f435 100644
--- a/design-notes.html
+++ b/design-notes.html
@@ -10,7 +10,7 @@
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="/~esr/index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 2001/06/24 19:23:57 $
+<td width="30%" align=right>$Date: 2001/07/31 05:54:40 $
</table>
<HR>
<H1 ALIGN=CENTER>Design Notes On Fetchmail</H1>
@@ -455,15 +455,15 @@ all shaped the design in one way or another.<P>
<DL>
<DT><A HREF="ftp://ftp.isi.edu/in-notes/rfc821.txt">RFC821</A>
-<DD> SMTP protocol
+<DD> SMTP protocol
<DT><A HREF="ftp://ftp.isi.edu/in-notes/rfc822.txt">RFC822</A>
-<DD> Mail header format
+<DD> Mail header format
<DT><A HREF="ftp://ftp.isi.edu/in-notes/rfc937.txt">RFC937</A>
-<DD> Post Office Protocol - Version 2
+<DD> Post Office Protocol - Version 2
<DT><A HREF="ftp://ftp.isi.edu/in-notes/rfc974.txt">RFC974</A>
-<DD> MX routing
+<DD> MX routing
<DT><A HREF="ftp://ftp.isi.edu/in-notes/rfc976.txt">RFC976</A>
-<DD> UUCP mail format
+<DD> UUCP mail format
<DT><A HREF="ftp://ftp.isi.edu/in-notes/rfc1081.txt">RFC1081</A>
<DD> Post Office Protocol - Version 3
<DT><A HREF="ftp://ftp.isi.edu/in-notes/rfc1123.txt">RFC1123</A>
@@ -537,9 +537,13 @@ all shaped the design in one way or another.<P>
<DT><A HREF="ftp://ftp.isi.edu/in-notes/rfc2683.txt">RFC2683</A>
<DD> IMAP4 Implementation Recommendations
<DT><A HREF="ftp://ftp.isi.edu/in-notes/rfc2595.html">RFC2595</A>
-<DD>Using TLS with IMAP, POP3 and ACAP
+<DD> Using TLS with IMAP, POP3 and ACAP
<DT><A HREF="ftp://ftp.isi.edu/in-notes/rfc2645.html">RFC2645</A>
<DD>On-Demand Mail Relay: SMTP with Dynamic IP Addresses
+<DT><A HREF="ftp://ftp.isi.edu/in-notes/rfc2821.html">RFC2821</A>
+<DD> Simple Mail Transfer Protocol
+<DT><A HREF="ftp://ftp.isi.edu/in-notes/rfc2822.txt">RFC2822</A>
+<DD>Internet Message Format
</DL>
<!--
RFC2192 IMAP URL Scheme
@@ -551,7 +555,7 @@ RFC2221 IMAP4 Login Referrals
<table width="100%" cellpadding=0><tr>
<td width="30%">Back to <a href="index.html">Fetchmail Home Page</a>
<td width="30%" align=center>To <a href="/~esr/sitemap.html">Site Map</a>
-<td width="30%" align=right>$Date: 2001/06/24 19:23:57 $
+<td width="30%" align=right>$Date: 2001/07/31 05:54:40 $
</table>
<P><ADDRESS>Eric S. Raymond <A HREF="mailto:esr@thyrsus.com">&lt;esr@snark.thyrsus.com&gt;</A></ADDRESS>
diff --git a/fetchmail.man b/fetchmail.man
index 00f2072d..21f11e04 100644
--- a/fetchmail.man
+++ b/fetchmail.man
@@ -273,7 +273,7 @@ POP3, ETRN, or ODMR.
Tell fetchail to poll trace information in the form `polling %s
account %s' to the Received line it generates, where the %s parts are
replaced by the user's remote name and the poll label (the Received
-header also normally inclodes the server's truename). This can be
+header also normally includes the server's truename). This can be
used to facilate mail filtering based on the account it is being
received from.
.TP
@@ -1802,12 +1802,13 @@ in a multi-user entry must include it. Here's an example:
.nf
poll pop.provider.net proto pop3 port 3111
user "jsmith" with pass "secret1" is "smith" here
- user jones with pass "secret2" is "jjones" here
+ user jones with pass "secret2" is "jjones" here keep
.fi
This associates the local username `smith' with the pop.provider.net
username `jsmith' and the local username `jjones' with the
-pop.provider.net username `jones'.
+pop.provider.net username `jones'. Mail for `jones' is kept on the
+server after download.
.PP
Here's what a simple retrieval configuration for a multi-drop mailbox
looks like:
@@ -2189,10 +2190,10 @@ mutt(1), elm(1), mail(1), sendmail(8), popd(8), imapd(8), netrc(5)
.SH APPLICABLE STANDARDS
.TP 5
SMTP/ESMTP:
-RFC 821, RFC 1869, RFC 1652, RFC 1870, RFC1983, RFC 1985
+RFC 821, RFC2821, RFC 1869, RFC 1652, RFC 1870, RFC1983, RFC 1985
.TP 5
mail:
-RFC 822, RFC 1123, RFC 1892, RFC 1894
+RFC 822, RFC2822, RFC 1123, RFC 1892, RFC 1894
.TP 5
POP2:
RFC 937
diff --git a/imap.c b/imap.c
index cfc85fa6..7ea1ef98 100644
--- a/imap.c
+++ b/imap.c
@@ -672,13 +672,19 @@ static int imap_fetch_headers(int sock, struct query *ctl,int number,int *lenp)
gen_send(sock, "FETCH %d RFC822.HEADER", number);
/* looking for FETCH response */
- do {
+ for (;;)
+ {
int ok;
if ((ok = gen_recv(sock, buf, sizeof(buf))))
return(ok);
- } while
- (sscanf(buf+2, "%d FETCH (%*s {%d}", &num, lenp) != 2);
+ if (sscanf(buf+2, "%d FETCH (%*s {%d}", &num, lenp) == 2)
+ break;
+ else if (sscanf(buf+2, "%d NO", &num) == 1)
+ return(PS_ERROR);
+ else if (sscanf(buf+2, "%d BAD", &num) == 1)
+ return(PS_ERROR);
+ }
if (num != number)
return(PS_ERROR);
diff --git a/indexgen.sh b/indexgen.sh
index df7cd4b0..f0350333 100755
--- a/indexgen.sh
+++ b/indexgen.sh
@@ -326,6 +326,13 @@ that assists you in installing sendmail and fetchmail together/
href="http://www.hawkins.emu.id.au/gotmail/">gotmail</a>
that can retrieve Hotmail.
+<P>A hacker identifying himself simply as `Steines' has written a
+filter which rewrites the to-line with a line which only includes
+receipients for a given domain and renames the old to-line. It also
+rewrites the domainpart of addresses if the offical domain is
+different to local domain. You can find it <a
+href="http://www.steines.com/mailf/">here</a>.
+
<H1>Fetchmail's funniest fan letter:</H1>
<A HREF="funny.html">This letter</A> still cracks me up whenever I reread it.
diff --git a/rcfile_y.y b/rcfile_y.y
index e034d566..523be003 100644
--- a/rcfile_y.y
+++ b/rcfile_y.y
@@ -100,8 +100,11 @@ statement : SET LOGFILE optmap STRING {run.logfile = xstrdup($4);}
| SET NO SPAMBOUNCE {run.spambounce = FALSE;}
| SET PROPERTIES optmap STRING {run.properties =xstrdup($4);}
| SET SYSLOG {run.use_syslog = TRUE;}
+ | SET NO SYSLOG {run.use_syslog = FALSE;}
| SET INVISIBLE {run.invisible = TRUE;}
+ | SET NO INVISIBLE {run.invisible = FALSE;}
| SET SHOWDOTS {run.showdots = TRUE;}
+ | SET NO SHOWDOTS {run.showdots = FALSE;}
/*
* The way the next two productions are written depends on the fact that
diff --git a/sink.c b/sink.c
index 061c9a97..502e989d 100644
--- a/sink.c
+++ b/sink.c
@@ -637,7 +637,7 @@ int open_sink(struct query *ctl, struct msgblk *msg,
"%s@%s", ctl->remotename, ctl->server.truename);
ap = addr;
}
- else if (strchr(msg->return_path, '@'))
+ else if (strchr(msg->return_path,'@') || strchr(msg->return_path,'!'))
ap = msg->return_path;
else /* in case Return-Path existed but was local */
{